Open Bug 1743264 Opened 9 months ago Updated 7 months ago

Newsgroup settings lost after new post to ignored thread (comment #0) - Selecting unread threads sometimes fails (comment #3)

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 91
defect

Tracking

(Not tracked)

UNCONFIRMED

People

(Reporter: newsfan, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/96.0.4664.45 Safari/537.36

Steps to reproduce:

Join newsgroup mozilla.test on server news.mozilla.org.

Currently there is a thread "Testin Spell Checker".

  • View a message in that tread and click "Followup".
  • Then ignore that thread (Ignore Thread on right-click menu).
  • Set the view to "Sort by Threaded" and "Threads > Unread"
  • Send the follow-up message.
  • On the newsgroup, right-click, "Get all messages". Note that you won't see the message since it's in an ignored thread.
  • Switch to a different folder.
  • Return to the newsgroup folder.

Actual results:

  • The view settings ("Sort by Threaded" and "Threads > Unread") are lost.

Expected results:

  • View settings should have been preserved.

Also, lots of weird stuff happens with the menus, on the right-click menu for the newsgroup items are disabled and items are also disabled in the View menu.

Alice, this was apparently working in TB 78. Can you please find the regression for us. It's a tricky one.

Blocks: tb91found
Flags: needinfo?(alice0775)
Keywords: regression
Component: Untriaged → Folder and Message Lists

It works or me in tb91.3.2 Windows10.

Flags: needinfo?(alice0775)

There are weird things going on. You can get the system into the situation where after setting "View > Threads > Unread", the "Sort By" and the "Threads" Menu items are both disabled and no messages are displayed despite showing 431 unread of 490 in the status bar.

(In reply to Alice0775 White from comment #2)

It works or me in tb91.3.2 Windows10.

Thanks for trying. There are a few strange things going on reported on alt.comp.software.thunderbird, including the one from comment #3 which I managed to reproduce. The so far, I couldn't reproduce the issue from comment #0 again. I'll get back to you with when I have a reproducible case.

When it goes wrong, this is the error:
An error occurred executing the cmd_viewUnreadMsgs command: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIMsgDBView.open]" nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)" location: "JS frame :: resource:///modules/DBViewWrapper.jsm :: _createView :: line 1113" data: no]
https://searchfox.org/comm-central/rev/d7b85cc6ed17562df5e156879087c803f7951320/mail/modules/DBViewWrapper.jsm#1113

So far it's completely unclear how to trigger this.

Summary: Newsgroup settings lost after new post to ignored thread → Newsgroup settings lost after new post to ignored thread (comment #0) - Selecting unread threads sometimes fails (comment #3)

I was one of the users who initially reported this problem on the newsgroup. I have been using the mozilla clients for probably 20 years, or as long as I can remember anyway. I have always selected view/ sort by/subject,ascending, and threaded. Then view/threads/unread. Has always worked for me until ver 92. Happens on both win 10 and win 7 machine. Half of the groups I subscribe to have the issue of these settings not sticking, the other half work just fine.

Today I tried subscribing to some new groups to see if I could figure out what sequence was causing this problem. No matter what I tried as far as sorting, when I marked things as read, numbers of groups I subscribed to at a time, any variable I could think of, nothing produced the error and all new groups immediately worked as they should and always have.

I tried unsubscribing from one of the groups this error was manifesting itself, closing down, and then resubscribing. It again loaded all the messages as new, and then worked through what I suppose was my rules and filtering file that was left behind. upon setting the rules as I wanted, it went back to working as it did before and would not save the settings. I'm wondering if somehow the the retained filter rules file is causing this.

I know you need to find what the problem is, but I think to make the client usable for now I have to continue seeing if this might be of value to me. I guess what users like me would need to know is what specific files could we isolate to see if removing them eliminates any chance it is being caused by these retained past files and then reinserting them to see if it reappears. That might at least narrow down the location of where the problem is coming from??? If it is these files, we could always build new filters.

Original reference to the issue in alt.comp.software.thunderbird, post entitled "The newsreader issue" of 5 Nov 2021 2:09 (1:09 GMT, 4 Nov 2021 20:09:41 -0500) with Message-ID: <sm208m$6c1$1@dont-email.me>. Interesting answer with STR in the first reply from Phil, Message-ID: <sm32hk$407$1@dont-email.me>.

You need to log in before you can comment on or make changes to this bug.