[FEATURE] Implement the Sort Bookmarks feature

VERIFIED FIXED in M16

Status

SeaMonkey
Bookmarks & History
P3
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: askman, Assigned: Steve Lamm)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Bring back the Sort feature that was present in Netscape 3.  I cannot see
any ad

vantage of speed or access to bookmarks via the removal of the Sort
feature.

Updated

18 years ago
Assignee: beard → ekrock

Comment 1

18 years ago
I guess this is a feature request.
Assignee: ekrock → johng
Summary: Bring back the Sort → [FEATURE] Implement the Sort Bookmarks feature
Target Milestone: M15
I assume you're referring to the "Sort Bookmarks" feature I see under the Item
menu of the "Go To Bookmarks" window in the 3.04 UI.

In Nav4 we had View-->Sort Ascending/Descending menu items in the equivalent UI.

Don't know what the plans are for Nav5, but I assume we have something similar
planned and that this is just a feature not implemented yet. Marking [FEATURE],
setting to M15, and reassigning to johng, the Bookmarks PM.

Comment 3

18 years ago
Please don't make this too easy to hit by accident. Or at least make it easily
undoable. I try to keep my bookmarks organized logically, and sorting them
alphabetically would be catastrophic.
Everything possible should be undoable.

Comment 5

18 years ago
Please make this sort feature work. The sort feature in 4.x was basically useless.
*** Bug 18335 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Component: Views → Bookmarks

Updated

18 years ago
Assignee: johng → slamm

Comment 7

18 years ago
I am cc'ing German Bauer on this since he has a UI spec on how this should work.
 Also assigning to slamm since I think he is the engineer on Don's team who will
implement this (but I might be wrong).

Comment 8

18 years ago
Move to M16 for now ...
Target Milestone: M15 → M16

Comment 9

18 years ago
resolving as fixed, last I checked we can sort bookmarks several different ways 
now.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
QA Contact: petersen → claudius
Resolution: --- → FIXED

Comment 10

18 years ago
marking VERIFIED
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.