Closed Bug 1744179 Opened 2 months ago Closed 2 months ago

Intermittent devtools/client/webconsole/test/browser/browser_console_content_object_in_sidebar.js | Uncaught exception - at chrome://mochitests/content/browser/devtools/client/shared/test/shared-head.js:1308 - TypeError: can't access property "scrollInto

Categories

(DevTools :: Console, defect, P5)

defect

Tracking

(firefox96 fixed)

RESOLVED FIXED
96 Branch
Tracking Status
firefox96 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: nchevobbe)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Filed by: smolnar [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer?job_id=360041344&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/arRbBUlKSTGzImxrgd53vg/runs/0/artifacts/public/logs/live_backing.log


INFO - TEST-START | devtools/client/webconsole/test/browser/browser_console_content_object_in_sidebar.js
[task 2021-12-03T01:30:22.552Z] 01:30:22     INFO - TEST-INFO | started process screentopng
[task 2021-12-03T01:30:22.864Z] 01:30:22     INFO - TEST-INFO | screentopng: exit 0
[task 2021-12-03T01:30:22.865Z] 01:30:22     INFO - Buffered messages logged at 01:30:21
[task 2021-12-03T01:30:22.871Z] 01:30:22     INFO - Entering test bound 
[task 2021-12-03T01:30:22.872Z] 01:30:22     INFO - Adding a new tab with URL: data:text/html;charset=utf8,<script>
[task 2021-12-03T01:30:22.873Z] 01:30:22     INFO -   console.log(
[task 2021-12-03T01:30:22.874Z] 01:30:22     INFO -     {a:1},
[task 2021-12-03T01:30:22.874Z] 01:30:22     INFO -     100,
[task 2021-12-03T01:30:22.874Z] 01:30:22     INFO -     {b:1},
[task 2021-12-03T01:30:22.874Z] 01:30:22     INFO -     'foo',
[task 2021-12-03T01:30:22.874Z] 01:30:22     INFO -     false,
[task 2021-12-03T01:30:22.874Z] 01:30:22     INFO -     null,
[task 2021-12-03T01:30:22.874Z] 01:30:22     INFO -     undefined
[task 2021-12-03T01:30:22.874Z] 01:30:22     INFO -   );
[task 2021-12-03T01:30:22.874Z] 01:30:22     INFO - </script>
[task 2021-12-03T01:30:22.874Z] 01:30:22     INFO - Console message: [JavaScript Warning: "This page is in Quirks Mode. Page layout may be impacted. For Standards Mode use “<!DOCTYPE html>”." {file: "data:text/html;charset=utf8,<script>  console.log(    {a:1},    100,    {b:1},    'foo',    false,    null,    undefined  );</script>" line: 0}]
[task 2021-12-03T01:30:22.874Z] 01:30:22     INFO - Tab added and finished loading
[task 2021-12-03T01:30:22.875Z] 01:30:22     INFO - Open the Browser Console
[task 2021-12-03T01:30:22.875Z] 01:30:22     INFO - Buffered messages logged at 01:30:22
[task 2021-12-03T01:30:22.875Z] 01:30:22     INFO - Console message: [JavaScript Warning: "The Web Console logging API (console.log, console.info, console.warn, console.error) has been disabled by a script on this page."]
[task 2021-12-03T01:30:22.875Z] 01:30:22     INFO - Showing sidebar for {a:1}
[task 2021-12-03T01:30:22.875Z] 01:30:22     INFO - Buffered messages finished
[task 2021-12-03T01:30:22.875Z] 01:30:22     INFO - TEST-UNEXPECTED-FAIL | devtools/client/webconsole/test/browser/browser_console_content_object_in_sidebar.js | Uncaught exception - at chrome://mochitests/content/browser/devtools/client/shared/test/shared-head.js:1308 - TypeError: can't access property "scrollIntoView", el is undefined
[task 2021-12-03T01:30:22.875Z] 01:30:22     INFO - Stack trace:
[task 2021-12-03T01:30:22.875Z] 01:30:22     INFO - synthesizeContextMenuEvent@chrome://mochitests/content/browser/devtools/client/shared/test/shared-head.js:1308:3
[task 2021-12-03T01:30:22.875Z] 01:30:22     INFO - openContextMenu@chrome://mochitests/content/browser/devtools/client/webconsole/test/browser/head.js:398:29
[task 2021-12-03T01:30:22.875Z] 01:30:22     INFO - showSidebarWithContextMenu@chrome://mochitests/content/browser/devtools/client/webconsole/test/browser/browser_console_content_object_in_sidebar.js:129:29
[task 2021-12-03T01:30:22.876Z] 01:30:22     INFO - @chrome://mochitests/content/browser/devtools/client/webconsole/test/browser/browser_console_content_object_in_sidebar.js:45:9
[task 2021-12-03T01:30:22.876Z] 01:30:22     INFO - Async*Tester_execTest/<@chrome://mochikit/content/browser-test.js:1091:34
[task 2021-12-03T01:30:22.876Z] 01:30:22     INFO - Tester_execTest@chrome://mochikit/content/browser-test.js:1131:11
[task 2021-12-03T01:30:22.876Z] 01:30:22     INFO - nextTest/<@chrome://mochikit/content/browser-test.js:939:14
[task 2021-12-03T01:30:22.876Z] 01:30:22     INFO - SimpleTest.waitForFocus/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:1041:13
[task 2021-12-03T01:30:22.876Z] 01:30:22     INFO - Leaving test bound 
[task 2021-12-03T01:30:22.877Z] 01:30:22     INFO - Clear the browser console output
[task 2021-12-03T01:30:22.877Z] 01:30:22     INFO - Browser console cleared
[task 2021-12-03T01:30:22.878Z] 01:30:22     INFO - Wait for all Browser Console targets to be attached
[task 2021-12-03T01:30:22.879Z] 01:30:22     INFO - Waiting 1 seconds.
[task 2021-12-03T01:30:22.879Z] 01:30:22     INFO - Close the Browser Console
 INFO - GECKO(1565) | console.warn: "IGNORED REDUX ACTION:" "MESSAGES_ADD"
[task 2021-12-03T01:30:22.881Z] 01:30:22     INFO - GECKO(1565) | JavaScript error: , line 0: NotFoundError: No such JSWindowActor 'DevToolsFrame'
[task 2021-12-03T01:30:22.882Z] 01:30:22     INFO - GECKO(1565) | JavaScript error: , line 0: NotFoundError: No such JSWindowActor 'DevToolsFrame'
[task 2021-12-03T01:30:22.883Z] 01:30:22     INFO - GECKO(1565) | JavaScript error: , line 0: NotFoundError: No such JSWindowActor 'DevToolsFrame'
[task 2021-12-03T01:30:22.883Z] 01:30:22     INFO - Browser Console closed
[task 2021-12-03T01:30:22.884Z] 01:30:22     INFO - Removing tab.
[task 2021-12-03T01:30:22.885Z] 01:30:22     INFO - Waiting for event: 'TabClose' on [object XULElement].
[task 2021-12-03T01:30:22.886Z] 01:30:22     INFO - Got event: 'TabClose' on [object XULElement].
[task 2021-12-03T01:30:22.887Z] 01:30:22     INFO - Tab removed and finished closing
[task 2021-12-03T01:30:22.887Z] 01:30:22     INFO - GECKO(1565) | JavaScript error: , line 0: NotFoundError: No such JSWindowActor 'DevToolsFrame'
[task 2021-12-03T01:30:22.888Z] 01:30:22     INFO - GECKO(1565) | JavaScript error: , line 0: NotFoundError: No such JSWindowActor 'DevToolsFrame'
[task 2021-12-03T01:30:22.889Z] 01:30:22     INFO - GECKO(1565) | JavaScript error: , line 0: NotFoundError: No such JSWindowActor 'DevToolsFrame'
[task 2021-12-03T01:30:22.890Z] 01:30:22     INFO - GECKO(1565) | JavaScript error: , line 0: NotFoundError: No such JSWindowActor 'DevToolsFrame'
[task 2021-12-03T01:30:22.891Z] 01:30:22     INFO - Console message: [JavaScript Error: "NotFoundError: No such JSWindowActor 'DevToolsFrame'"]
[task 2021-12-03T01:30:22.892Z] 01:30:22     INFO - Console message: [JavaScript Error: "NotFoundError: No such JSWindowActor 'DevToolsFrame'"]
[task 2021-12-03T01:30:22.893Z] 01:30:22     INFO - Console message: [JavaScript Error: "NotFoundError: No such JSWindowActor 'DevToolsFrame'"]
[task 2021-12-03T01:30:22.894Z] 01:30:22     INFO - GECKO(1565) | console.warn: "IGNORED REDUX ACTION:" "AUTOCOMPLETE_CLEAR"
[task 2021-12-03T01:30:23.388Z] 01:30:23     INFO - GECKO(1565) | JavaScript error: , line 0: NotFoundError: No such JSWindowActor 'DevToolsFrame'
[task 2021-12-03T01:30:23.389Z] 01:30:23     INFO - Console message: [JavaScript Error: "NotFoundError: No such JSWindowActor 'DevToolsFrame'"]
[task 2021-12-03T01:30:23.390Z] 01:30:23     INFO - Console message: [JavaScript Error: "NotFoundError: No such JSWindowActor 'DevToolsFrame'"]
[task 2021-12-03T01:30:23.392Z] 01:30:23     INFO - Console message: [JavaScript Error: "NotFoundError: No such JSWindowActor 'DevToolsFrame'"]
[task 2021-12-03T01:30:23.393Z] 01:30:23     INFO - Console message: [JavaScript Error: "NotFoundError: No such JSWindowActor 'DevToolsFrame'"]
[task 2021-12-03T01:30:23.401Z] 01:30:23     INFO - TEST-PASS | devtools/client/webconsole/test/browser/browser_console_content_object_in_sidebar.js | The main process DevToolsServer has no pending connection when the test ends -

@Nicolas, can you take a look at these failures?
Backfill and retriggers indicate they start from Bug 1238861

Flags: needinfo?(nchevobbe)

I know what's going on, I'll provide a patch today

Flags: needinfo?(nchevobbe)

Now what we show a warning message on pages with invalid/no doctype,
a lot of tests were failing because of it.
This patch only adds doctype on all webconsole test pages.

Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
Attachment #9253616 - Attachment description: Bug 1744179 - [devtools] Add doctype to all webconsole test pages. r=me. → Bug 1744179 - [devtools] Add doctype to all webconsole test pages.
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/92df9c655be5
[devtools] Add doctype to all webconsole test pages.
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 96 Branch
Duplicate of this bug: 1744183
You need to log in before you can comment on or make changes to this bug.