Closed Bug 1744667 Opened 5 months ago Closed 5 months ago

Perma 0:12.04 toolkit/components/glean/tests/pytest/test_no_expired_metrics.py::test_no_metrics_expired TEST-UNEXPECTED-FAIL

Categories

(Core :: DOM: Core & HTML, defect, P5)

defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox-esr91 --- unaffected
firefox95 --- wontfix
firefox96 --- fixed
firefox97 --- fixed

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Regression)

Details

(Keywords: intermittent-failure, regression)

Filed by: malexandru [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer?job_id=360345211&repo=mozilla-central
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/Wm42-MYQReaWzHnKtTMAOg/runs/0/artifacts/public/logs/live_backing.log


[task 2021-12-07T02:29:41.874Z]  0:10.99 toolkit/components/glean/tests/pytest/test_glean_parser_rust.py::test_numeric_expires PASSED
[task 2021-12-07T02:29:41.874Z]  0:10.99 
[task 2021-12-07T02:29:41.875Z]  0:10.99 =========================== 4 passed in 0.87 seconds ===========================
[task 2021-12-07T02:29:42.930Z]  0:12.04 /builds/worker/checkouts/gecko/toolkit/components/glean/tests/pytest/test_no_expired_metrics.py
[task 2021-12-07T02:29:42.930Z]  0:12.04 ============================= test session starts ==============================
[task 2021-12-07T02:29:42.930Z]  0:12.04 platform linux -- Python 3.6.9, pytest-3.6.2, py-1.4.33, pluggy-0.4.0 -- /builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/_virtualenvs/python-test/bin/python
[task 2021-12-07T02:29:42.930Z]  0:12.04 rootdir: /builds/worker/checkouts/gecko, inifile: /builds/worker/checkouts/gecko/config/mozunit/mozunit/pytest.ini
[task 2021-12-07T02:29:42.930Z]  0:12.04 collecting ... collected 1 item
[task 2021-12-07T02:29:42.931Z]  0:12.04 
[task 2021-12-07T02:29:42.931Z]  0:12.04 toolkit/components/glean/tests/pytest/test_no_expired_metrics.py::test_no_metrics_expired TEST-UNEXPECTED-FAIL
[task 2021-12-07T02:29:42.931Z]  0:12.04 
[task 2021-12-07T02:29:42.931Z]  0:12.04 =================================== FAILURES ===================================
[task 2021-12-07T02:29:42.931Z]  0:12.04 ___________________________ test_no_metrics_expired ____________________________
[task 2021-12-07T02:29:42.931Z]  0:12.04 
[task 2021-12-07T02:29:42.931Z]  0:12.04     def test_no_metrics_expired():
[task 2021-12-07T02:29:42.931Z]  0:12.04         """
[task 2021-12-07T02:29:42.931Z]  0:12.04         Of all the metrics included in this build, are any expired?
[task 2021-12-07T02:29:42.931Z]  0:12.04         If so, they must be removed or renewed.
[task 2021-12-07T02:29:42.931Z]  0:12.04 
[task 2021-12-07T02:29:42.932Z]  0:12.04         (This also checks other lints, as a treat.)
[task 2021-12-07T02:29:42.932Z]  0:12.04         """
[task 2021-12-07T02:29:42.932Z]  0:12.04         with open("browser/config/version.txt", "r") as version_file:
[task 2021-12-07T02:29:42.932Z]  0:12.04             app_version = version_file.read().strip()
[task 2021-12-07T02:29:42.932Z]  0:12.04 
[task 2021-12-07T02:29:42.932Z]  0:12.04         options = run_glean_parser.get_parser_options(app_version)
[task 2021-12-07T02:29:42.932Z]  0:12.04         metrics_paths = [Path(x) for x in metrics_yamls]
[task 2021-12-07T02:29:42.932Z]  0:12.05         all_objs = parser.parse_objects(metrics_paths, options)
[task 2021-12-07T02:29:42.932Z]  0:12.05         assert not util.report_validation_errors(all_objs)
[task 2021-12-07T02:29:42.932Z]  0:12.05 >       assert not lint.lint_metrics(all_objs.value, options)
[task 2021-12-07T02:29:42.933Z]  0:12.05 E       AssertionError: assert not [<glean_parser.lint.GlinterNit object at 0x7f9910ac1668>]
[task 2021-12-07T02:29:42.933Z]  0:12.05 E        +  where [<glean_parser.lint.GlinterNit object at 0x7f9910ac1668>] = <function lint_metrics at 0x7f9910cc1158>(OrderedDict([('fog', OrderedDict([('initialization', <glean_parser.metrics.Timespan object at 0x7f991262cba8>), ('fail...owser.link', OrderedDict([('open_newwindow_restriction', <glean_parser.metrics.Quantity object at 0x7f9910ac12e8>)]))]), {'allow_reserved': False, 'custom_is_expired': <function get_parser_options.<locals>.<lambda> at 0x7f9912aa7d90>, 'custom_validate_expires': <function get_parser_options.<locals>.<lambda> at 0x7f9910ac02f0>})
[task 2021-12-07T02:29:42.933Z]  0:12.05 E        +    where <function lint_metrics at 0x7f9910cc1158> = lint.lint_metrics
[task 2021-12-07T02:29:42.933Z]  0:12.05 E        +    and   OrderedDict([('fog', OrderedDict([('initialization', <glean_parser.metrics.Timespan object at 0x7f991262cba8>), ('fail...owser.link', OrderedDict([('open_newwindow_restriction', <glean_parser.metrics.Quantity object at 0x7f9910ac12e8>)]))]) = <glean_parser.util.keep_value.<locals>.ValueKeepingGenerator object at 0x7f9910abc898>.value
[task 2021-12-07T02:29:42.933Z]  0:12.05 
[task 2021-12-07T02:29:42.933Z]  0:12.05 toolkit/components/glean/tests/pytest/test_no_expired_metrics.py:41: AssertionError
[task 2021-12-07T02:29:42.933Z]  0:12.05 =========================== 1 failed in 0.44 seconds ===========================
[task 2021-12-07T02:29:42.933Z]  0:12.05 Sorry, Glean found some glinter nits:
[task 2021-12-07T02:29:42.934Z]  0:12.05 WARNING: EXPIRED: browser.link.open_newwindow_restriction: Metric has expired. Please consider removing it.
[task 2021-12-07T02:29:42.934Z]  0:12.05 
[task 2021-12-07T02:29:42.934Z]  0:12.05 Please fix the above nits to continue.
[task 2021-12-07T02:29:42.934Z]  0:12.05 To disable a check, add a `no_lint` parameter with a list of check names to disable.
[task 2021-12-07T02:29:42.935Z]  0:12.05 This parameter can appear with each individual metric, or at the top-level to affect the entire file.
[task 2021-12-07T02:29:42.935Z]  0:12.05 Setting retcode to 1 from /builds/worker/checkouts/gecko/toolkit/components/glean/tests/pytest/test_no_expired_metrics.py
[task 2021-12-07T02:29:42.935Z]  0:12.05 Return code from mach python-test: 1
[task 2021-12-07T02:29:42.962Z] Creating default state directory: /builds/worker/.mozbuild
[task 2021-12-07T02:29:42.962Z] Test configuration changed. Regenerating backend.
[task 2021-12-07T02:29:42.962Z] No build detected, test metadata may be incomplete.
[taskcluster 2021-12-07 02:29:43.451Z] === Task Finished ===
[taskcluster 2021-12-07 02:29:43.452Z] Unsuccessful task run with exit code: 1 completed in 31.416 seconds

Chris, I think this is related to the recent bump to the mozilla-central version, could you please take a look?

Flags: needinfo?(chutten)

browser.link.open_newwindow_restriction is expired. Recomponenting bug based on the expired metric.

I'm sorry, there were supposed to be emails sent which would warn of upcoming metrics failures but we don't yet have that capability. I'll be looking into fixing that presently.

Component: Telemetry → DOM: Core & HTML
Flags: needinfo?(chutten)
Product: Toolkit → Core
Regressed by: 1740063
Has Regression Range: --- → yes
Flags: needinfo?(arai.unmht)

bug 1744591 has a patch to remove the telemetry

Depends on: 1744591
Flags: needinfo?(arai.unmht)

Set release status flags based on info from the regressing bug 1740063

I think we can closed this as resolved fixed since the patch in Bug 1744591 landed and no recent failures have appeared.

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.