Drag selecting text from right to left is extremely slow when scrolling

RESOLVED WORKSFORME

Status

Camino Graveyard
General
--
minor
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Jason Trindade, Assigned: saari (gone))

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
This occurs in the 10/14 build when viewing a page that is wider than the
display (mines 1024 x 768). If I scroll to the right, place the insertion point
at the end of a line, then drag back to the left the scroll bar that moves the
page moves it extremely slowly. It is slower than if I were to move the
scrollbar by an order of magnitude. As an example I selected:

 http://creative.gettyimages.com/source/search/resultsmain.asp?source=advSearch&hdnSync=black+child+arms+crossed~0%2C12%2C449%2C3%2C15%2C1%2C0%2C0%2C0%2C12287%2C0%2C0%2C0%2C0%2C0%2C%2C%2C%2C16%2Cen-us&UQR=dcgzbc

but it also occurs with any text that spills past the current scroll point (what
do we call that?)

Comment 1

16 years ago
Perhaps it's a duplicate of 'Now slower when multiple frames'
http://bugzilla.mozilla.org/show_bug.cgi?id=164492

The gettyimages page is made of 2 frames, reduce window width to see 2 scroll bars.
WFM with 1026 OS X 10.1.5. (Perhaps it's a font smoothing problem mine is off in
.js).

The gettyimages site is also mentionned in bug 175587, javascript error on the site.

Comment 2

16 years ago
I'm not clear on whether this bug applies to text in text fields, or just on the
web page itself? Scrolling speed seems fine in both cases for me. Please reopen
if you still see the problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.