Closed Bug 1745033 Opened 3 years ago Closed 2 years ago

new NNTP implementation in JS is broken in TB96.0b1 - new and existing articles are not shown in preview pane - due to combination of primary password and permisssions.sqlite in the profile directory.

Categories

(MailNews Core :: Networking: NNTP, defect, P2)

Thunderbird 96

Tracking

(thunderbird_esr91 unaffected, thunderbird_esr102+ fixed, thunderbird96 wontfix, thunderbird99+ wontfix, thunderbird100+ wontfix, thunderbird103 affected)

RESOLVED FIXED
104 Branch
Tracking Status
thunderbird_esr91 --- unaffected
thunderbird_esr102 + fixed
thunderbird96 --- wontfix
thunderbird99 + wontfix
thunderbird100 + wontfix
thunderbird103 --- affected

People

(Reporter: chriechers, Assigned: rnons)

References

Details

(Keywords: regression)

Attachments

(4 files, 1 obsolete file)

TB 96.0b1 on Linux
I do have 3 NNTP accounts with multiple news groups in each account.
None of them pulls any new messages, and existing messages are not shown.
Clicking on any newsgroup in the folder pane does nothing.
The tab with a newsgroup selected just shows an hourglass in the tab bar.

The error console shows this:
Error: An unexpected error occurred undefined
TypeError: server.wrappedJSObject is undefined NntpService.jsm:100:5
getNewNews resource:///modules/NntpService.jsm:100
updateFolderAndNotifyOnLoad resource:///modules/DBViewWrapper.jsm:88
open resource:///modules/DBViewWrapper.jsm:810
show chrome://messenger/content/folderDisplay.js:849
openTab chrome://messenger/content/mailTabs.js:172
openTab chrome://messenger/content/tabmail.js:949
restoreTab chrome://messenger/content/mailTabs.js:280
restoreTab chrome://messenger/content/tabmail.js:1456
restoreTabs chrome://messenger/content/tabmail.js:1477
atStartupRestoreTabs chrome://messenger/content/msgMail3PaneWindow.js:1190
InterpretGeneratorResume self-hosted:1485
AsyncFunctionNext self-hosted:695
[Exception... "[JavaScript Error: "server.wrappedJSObject is undefined" {file: "resource:///modules/NntpService.jsm" line: 100}]'[JavaScript Error: "server.wrappedJSObject is undefined" {file: "resource:///modules/NntpService.jsm" line: 100}]' when calling method: [nsINntpService::getNewNews]" nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)" location: "JS frame :: resource:///modules/DBViewWrapper.jsm :: updateFolderAndNotifyOnLoad :: line 88" data: yes] DBViewWrapper.jsm:88:15
updateFolderAndNotifyOnLoad resource:///modules/DBViewWrapper.jsm:88
open resource:///modules/DBViewWrapper.jsm:810
show chrome://messenger/content/folderDisplay.js:849
openTab chrome://messenger/content/mailTabs.js:172
openTab chrome://messenger/content/tabmail.js:949
restoreTab chrome://messenger/content/mailTabs.js:280
restoreTab chrome://messenger/content/tabmail.js:1456
restoreTabs chrome://messenger/content/tabmail.js:1477
atStartupRestoreTabs chrome://messenger/content/msgMail3PaneWindow.js:1190
InterpretGeneratorResume self-hosted:1485
AsyncFunctionNext self-hosted:695
TypeError: server.wrappedJSObject is undefined NntpService.jsm:100:5
getNewNews resource:///modules/NntpService.jsm:100
MsgGetMessagesForAllServers chrome://messenger/content/mailWindowOverlay.js:1996
loadStartFolder chrome://messenger/content/msgMail3PaneWindow.js:1371
InterpretGeneratorResume self-hosted:1485
AsyncFunctionNext self-hosted:695

Same behavior with Windows 10.
NNTP did work with TB 95.0b5.

Component: General → Networking: NNTP
Flags: needinfo?(remotenonsense)
Keywords: regression
Product: Thunderbird → MailNews Core

Also a problem after restarting Thunderbird? I know I had something similar when testing patches, but never could reproduce after the first time it happened.

It's 100% reproducible here on two different Thunderbird beta installations, as well as on TB97 daily.
Also happens in safe mode.

Set mailnews.nntp.jsmodule to false in the Config Editor for now.

I changed the module registration order a bit in the patch for bug 1744946, let's see if it helps.

Flags: needinfo?(remotenonsense)

Can you update your daily and see if it's the same? Thanks.

Flags: needinfo?(chriechers)

Updated to Daily 97.0a1 (2021-12-10) (64-bit), and the problem persists.
From the error console:
TypeError: can't access property "withClient", server.wrappedJSObject is undefined NntpService.jsm:101:5
getNewNews resource:///modules/NntpService.jsm:101
updateFolderAndNotifyOnLoad resource:///modules/DBViewWrapper.jsm:88
open resource:///modules/DBViewWrapper.jsm:810
show chrome://messenger/content/folderDisplay.js:849
FolderPaneSelectionChange chrome://messenger/content/commandglue.js:364
onselect chrome://messenger/content/messenger.xhtml:1
MozTreeChildren chrome://global/content/elements/tree.js:69

Flags: needinfo?(chriechers)
Flags: needinfo?(remotenonsense)

Hi, any luck with 98 beta?

Flags: needinfo?(remotenonsense) → needinfo?(chriechers)

Unfortunately I cannot test with beta because it is crashing seconds after start (bug 1743138).
NNTP certainly is still broken in TB 99.0a1 (2022-02-09).

Flags: needinfo?(chriechers)

Now also tested with TB 98.0b2. Not surprisingly JS NNTP is still broken.

That's unfortunate, do you see any other errors before the wrappedJSObject error. In comment 0, there are several restoreTab calls, what are those tabs? Thanks

Attached image tab_bar.png

(In reply to Ping Chen (:rnons) from comment #10)

do you see any other errors before the wrappedJSObject error.

No, there is nothing before related to NNTP.

In comment 0, there are several restoreTab calls, what are those tabs?

I always have three tabs open:
Email (Inbox, or some other folder from one of the email accounts)
News (a newsgroup from one of the news servers)
RSS (a feed from one of the feeds I'm subscribed to)

The tabs are restored upon TB startup. Then the tab bar looks like this - see comment #11. The tab in the middle only showing a hourglass is the News tab.

Can you run this code in the Console and tell me the result

server = Cc['@mozilla.org/messenger/server;1?type=nntp'].createInstance(Ci.nsINntpIncomingServer)
server.wrappedJSObject?.withClient

I tried this with 99.0a1 (2022-02-16) (64-bit) on Linux.
Not exactly sure what's expected when running this. It does create a seemingly endless tree structure in the Console, but it's impossible to expand and export everything.
The result is attached - see console-export-2022-2-16_19-23-5.txt. Also included are any other NNTP related messages before and after.
Since the tree structure formatting gets lost in plain text it doesn't look pretty.

Thanks, it's good as long as it's a function, no need to expand the tree. It shows like this for me

async function withClient(handler)

Please run this code

servers = MailServices.accounts.allServers.filter(s => s.type == 'nntp')
servers[0].QueryInterface(Ci.nsINntpIncomingServer).wrappedJSObject?.withClient 
// if you have more than one nntp servers, repeat the above line like this
servers[1].QueryInterface(Ci.nsINntpIncomingServer).wrappedJSObject?.withClient 
...

withClient should be a function for each nntp server.

There is only one NNTP server in this test profile for daily.

servers = MailServices.accounts.allServers.filter(s => s.type == 'nntp')
servers[0].QueryInterface(Ci.nsINntpIncomingServer).wrappedJSObject?.withClient
undefined

Seems your accounts are loaded before NntpModuleLoader.jsm is run, do you have auto config or some special setup?

I'm not sure what exactly 'auto config' means here. AFAIK there is no special setup, this is an ordinary news account.

(In reply to Christian Riechers from comment #19)

I'm not sure what exactly 'auto config' means here. AFAIK there is no special setup, this is an ordinary news account.

I'm not sure either

Flags: needinfo?(remotenonsense)
Summary: new NNTP implementation in JS is broken in TB96.0b1 → new NNTP implementation in JS is broken in TB96.0b1 - new articles, and existing articles are not shown

With 99 beta I'm seeing this consistently, with hourglass in the tab bar and progress meter in status bar. But I don't see this immediately after startup. Possible triggers (I haven't fully nailed it down):

  • manually getting messages
  • (quickly?) switching between newsgroups or news servers

Restarting Thunderbird clears the condition for a short time. Change to mail folders or other newsgoups or servers does not help.

It seems worse to me in recent weeks, but I can't pin point a time frame.

Summary: new NNTP implementation in JS is broken in TB96.0b1 - new articles, and existing articles are not shown → new NNTP implementation in JS is broken in TB96.0b1 - new and existing articles are not shown in preview pane, hourglass in the tab bar

Amending comment 21, I don't see this immediately after startup.

(In reply to Ping Chen (:rnons) from comment #13)

Can you run this code in the Console and tell me the result

server = Cc['@mozilla.org/messenger/server;1?type=nntp'].createInstance(Ci.nsINntpIncomingServer)
server.wrappedJSObject?.withClient

Error in asyncStorage.setItem(): UnknownError async-storage.js:109:19
setItemOnError resource://devtools/shared/async-storage.js:109
11:47:27.521
Error when saving WebConsole input history DOMException: The operation failed for reasons unrelated to the database itself and not covered by any other error code. history-persistence.js:52:19
historyPersistenceMiddleware resource://devtools/client/webconsole/middleware/history-persistence.js:52
11:47:27.531
function withClient()
​ length: 1
​ name: "withClient"
​ <prototype>: Object { … }

Wayne, do you also see TypeError: can't access property "withClient", server.wrappedJSObject is undefined? From comment 22, withClient is defined, so seems like a different bug, let me know if you find a way to reproduce.

Flags: needinfo?(remotenonsense)

I'm not seeing the display issues any more.
Do you need more info from Christian?

Flags: needinfo?(remotenonsense)

Please share your OS/version and from where you download TB, I will run a VM to see if I can reproduce.

Flags: needinfo?(remotenonsense)

Mac 12.1 Thunderbird beta. currently 100. But I assume 99 at the time I reported. You might better rely on Christian's results.

(In reply to Ping Chen (:rnons) from comment #25)

Please share your OS/version and from where you download TB, I will run a VM to see if I can reproduce.

OpenSUSE Linux Tumbleweed, Thunderbird daily 04/13/22 from thunderbird.net

I installed Tumbleweed in Gnome Boxes and downloaded TB beta, created a news account, didn't see any problems.

Create a news account and subscribe to alt.binaries.pictures.scenic using 100.0b2.

The message pane is blank when trying to read a post.

Error Console shows.

12:31:40.832
NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgAccountManager.getIncomingServer] NntpUtils.jsm:50
findServer resource:///modules/NntpUtils.jsm:50
NntpChannel resource:///modules/NntpChannel.jsm:34
newChannel resource:///modules/NntpProtocolHandler.jsm:31
DisplayMessage resource:///modules/NntpMessageService.jsm:37
ThreadPaneSelectionChanged chrome://messenger/content/threadPane.js:507
onselect chrome://messenger/content/messenger.xhtml:1
MozTreeChildren chrome://global/content/elements/tree.js:69
12:31:40.836
NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgMailNewsUrl.loadURI] NntpMessageService.jsm:37
DisplayMessage resource:///modules/NntpMessageService.jsm:37
ThreadPaneSelectionChanged chrome://messenger/content/threadPane.js:507
onselect chrome://messenger/content/messenger.xhtml:1
MozTreeChildren chrome://global/content/elements/tree.js:69

My account is with Usenet-News.
Couldn't find a free account that carried that newsgroup.
Tested with only that account in a test profile on Windows 10 and Fedora 35 Workstation.

NNTP errors continue in TB100.0b2. The error console has:

TypeError: server.wrappedJSObject is undefinedNntpService.jsm:101:5
getNewNews resource:///modules/NntpService.jsm:101
MsgGetMessagesForAllServers chrome://messenger/content/mailWindowOverlay.js:2085
loadStartFolder chrome://messenger/content/msgMail3PaneWindow.js:1538
InterpretGeneratorResume self-hosted:1428
AsyncFunctionNext self-hosted:638

TypeError: server.wrappedJSObject is undefinedNntpService.jsm:101:5
getNewNews resource:///modules/NntpService.jsm:101
updateFolderAndNotifyOnLoad resource:///modules/DBViewWrapper.jsm:88
open resource:///modules/DBViewWrapper.jsm:810
show chrome://messenger/content/folderDisplay.js:849
FolderPaneSelectionChange chrome://messenger/content/commandglue.js:368
onselect chrome://messenger/content/messenger.xhtml:1
MozTreeChildren chrome://global/content/elements/tree.js:69

Uncaught
Exception { name: "NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS", message: "[JavaScript Error: "server.wrappedJSObject is undefined" {file: "resource:///modules/NntpService.jsm" line: 101}]'[JavaScript Error: "server.wrappedJSObject is undefined" {file: "resource:///modules/NntpService.jsm" line: 101}]' when calling method: [nsINntpService::getNewNews]", result: 2153185313, filename: "resource:///modules/DBViewWrapper.jsm", lineNumber: 88, columnNumber: 0, data: XPCWrappedNative_NoHelper, stack: "updateFolderAndNotifyOnLoad@resource:///modules/DBViewWrapper.jsm:88:15\nopen@resource:///modules/DBViewWrapper.jsm:810:32\nshow@chrome://messenger/content/folderDisplay.js:849:19\nFolderPaneSelectionChange@chrome://messenger/content/commandglue.js:368:18\nonselect@chrome://messenger/content/messenger.xhtml:1:1\nMozTreeChildren/<@chrome://global/content/elements/tree.js:69:28\n", location: XPCWrappedNative_NoHelper }
DBViewWrapper.jsm:88
updateFolderAndNotifyOnLoad resource:///modules/DBViewWrapper.jsm:88
open resource:///modules/DBViewWrapper.jsm:810
show chrome://messenger/content/folderDisplay.js:849
FolderPaneSelectionChange chrome://messenger/content/commandglue.js:368
onselect chrome://messenger/content/messenger.xhtml:1
MozTreeChildren chrome://global/content/elements/tree.js:69

This is with TB100.0 b3.
When deleting the existing news account and recreating it, I can subscribe to newsgroups, and it seems to work initially.
However, after restarting TB it's broken again, and cannot be recovered other than deleting and re-creating the news account.
News server: news.aioe.org, Connection security: SSL/TLS
subscribed newsgroups: alt.comp.software.firefox, alt.comp.software.thunderbird

I finally wanted to test this, but ran into bug 1766176. Without authentication, you only get the "home-made" newsgroups at news.eternal-september.org and for that, NNTP seems to work. I guess your server also requires auth, right?

Blocks: nntp-js

The problem persists with TB101.0 b1. It's getting pretty close now for v102.0.

With bug 1766176 fixed now, I revisited this. Some "regular" newsgroups like alt.comp.software.thunderbird seem to work. alt.binaries.pictures.scenic (comment #29) isn't served by news.eternal-september.org, but alt.binaries.pictures.gardens is and it works, at least there are lots of post with lots of pretty garden pictures. Christian, Walt, does this reproduce on news.eternal-september.org or only on news.aioe.org? And does it also fail on a new profile (sorry if you already answered that).

I'm not having any issue with text only groups on my news.aioe.org account.

I don't really want to register for a news.eternal-september.org account.

My issue is with alt.binaries.pictures.scenic using Usenet-News using my production or a test profile.

Since the group only receives around 5 new image posts a day, I can use the Pan newsreader to read it until my 110.5735 GB block quota last updated with a 100 GB block purchase in 2017 runs out. A 2 GB block is only $2 USD.

(In reply to newsfan from comment #34)

does this reproduce on news.eternal-september.org or only on news.aioe.org?

The news server doesn't matter, so yes, it does reproduce on news.eternal-september.org.

And does it also fail on a new profile (sorry if you already answered that).

I've only tried to delete and re-create the news account - see comment #31. I have not tried a new profile.

There were mixed results with a new profile.
In a new profile with both, IMAP email and NNTP, the problem did occur.
In a new profile with NNTP only, the problem did not occur.

The problem continues with TB 102.0b2.

I'm getting the following errors while trying to read newsgroup posts:
TypeError: MailServices.accounts.findServer(...) is null NntpMessageService.jsm:144:8
_decomposeNewsMessageURI resource:///modules/NntpMessageService.jsm:144
_createMessageIdUrl resource:///modules/NntpMessageService.jsm:164
getUrlForUri resource:///modules/NntpMessageService.jsm:56
DisplayMessage resource:///modules/NntpMessageService.jsm:32
As a result, I see list of the posts, but the body of the post is not presented, in both preview or after doubleclick mode.

Would it be the similar issue as discussed here or another bug should be opened?

EDIT: I'm facing it on stable Thunderbird 102.0. News server is aioe.org, without authentication, on both encrypted and non-encrypted connection.
Disabling JS nntp module brings everything back to normal.

(In reply to Roman Sąsiada from comment #39)

I'm getting the following errors while trying to read newsgroup posts:
TypeError: MailServices.accounts.findServer(...) is null NntpMessageService.jsm:144:8
_decomposeNewsMessageURI resource:///modules/NntpMessageService.jsm:144
_createMessageIdUrl resource:///modules/NntpMessageService.jsm:164
getUrlForUri resource:///modules/NntpMessageService.jsm:56
DisplayMessage resource:///modules/NntpMessageService.jsm:32
As a result, I see list of the posts, but the body of the post is not presented, in both preview or after doubleclick mode.

Would it be the similar issue as discussed here or another bug should be opened?

This is different, please open a new bug. What do you get when right click a message in the list, select "Copy Message Location"? I get something like news://nntp.aioe.org:119/t1234@abc.def. Does the hostname and port match your server settings on Account Settings page?

Bug 1777439 https://bugzilla.mozilla.org/show_bug.cgi?id=1777439 created.
Hostname and port from "Message location" match my server settings from account configuration

See Also: → 1777439
See Also: → 1778048

| TypeError: server.wrappedJSObject is undefinedNntpService.jsm:101:5

Does anyone else still use the profile where this error occurs when mailnews.nntp.jsmodule=TRUE?

Then could you please confirm that the error goes away when you set mailnews.nntp.jsmodule=TRUE but disable the primary password.

(In reply to Alfred Peters from comment #43)

Then could you please confirm that the error goes away when you set mailnews.nntp.jsmodule=TRUE but disable the primary password.

I can confirm this relationship with one at least once updated profile each for TB102.1, TB103.0b4, and TB104.0a1.

However, the error does not occur with a completely newly created profile.

(In reply to Alfred Peters from comment #43)

Then could you please confirm that the error goes away when you set mailnews.nntp.jsmodule=TRUE but disable the primary password.

I can confirm this. It's an old profile upgraded for each new beta release since quite a while. Without the primary password and mailnews.nntp.jsmodule set to true JS NNTP works.

(In reply to Alfred Peters from comment #44)

However, the error does not occur with a completely newly created profile.

I can confirm this as well. In a new profile, with a primary password set, and mailnews.nntp.jsmodule set to true there is no problem.

Attached image permission.sqlite.jpg

(In reply to Alfred Peters from comment #43)

Then could you please confirm that the error goes away when you set mailnews.nntp.jsmodule=TRUE but disable the primary password.

Thanks, I finally find out how to reproduce this. It's a combination of primary password and permisssions.sqlite in the profile directory.

As shown in the screenshot, there are three imap urls in my permisssions.sqlite, when primary password is enabled, the start up process is like

  1. PermissionManager reads permisssions.sqlite and calls NS_NewURI for each url, see https://searchfox.org/mozilla-central/rev/f41f31de675cc9ac0c17a7ad84c0b32cd08994c5/extensions/permissions/PermissionManager.cpp#264
  2. NS_NewURI calls https://searchfox.org/comm-central/rev/61eade1767e7756eb8cbdc6a6b6615a842df48ae/mailnews/imap/src/nsImapService.cpp#2356 and https://searchfox.org/comm-central/rev/61eade1767e7756eb8cbdc6a6b6615a842df48ae/mailnews/imap/src/nsImapService.cpp#2330, which then loads all accounts.

This happens before NntpModuleLoader.jsm, so nsNntpIncomingServer.cpp is used to init news accounts. Later NntpModuleLoader.jsm is ran and TB finishes starting up, now click the news folder will use NntpServices.jsm, which doesn't work with nsNntpIncomingServer.cpp.

I don't know how the three imap urls ended up in permisssions.sqlite, and what does the storageAccessAPI mean.

A fix might be reloading all accounts in NntpModuleLoader.jsm, I will see if it's possible to do.

(In reply to Ping Chen (:rnons) from comment #47)

I don't know how the three imap urls ended up in permisssions.sqlite, and what does the storageAccessAPI mean.

IMAP URLs in permisssions.sqlite are "normal", see bug 1575512 for details where they also caused a lot of strive. Read downwards from about cmt #27 of that bug.

(In reply to Alfred Peters from comment #43)

| TypeError: server.wrappedJSObject is undefinedNntpService.jsm:101:5

Does anyone else still use the profile where this error occurs when mailnews.nntp.jsmodule=TRUE?

Then could you please confirm that the error goes away when you set mailnews.nntp.jsmodule=TRUE but disable the primary password.

I can confirm.
I did not touch mailnews.nntp.jsmodule setting and I can see it is true.
Then:
when primary password is set - nntp does NOT work
when primary password is not set - nntp DOES work.
thunderbird from debian package 1:102.0.1-1 and also https://download-origin.cdn.mozilla.net/pub/thunderbird/releases/102.0.1/linux-x86_64/
tested on very old profile and also newly configured.

Summary: new NNTP implementation in JS is broken in TB96.0b1 - new and existing articles are not shown in preview pane, hourglass in the tab bar → new NNTP implementation in JS is broken in TB96.0b1 - new and existing articles are not shown in preview pane - due to combination of primary password and permisssions.sqlite in the profile directory.
Assignee: nobody → remotenonsense
Status: NEW → ASSIGNED
Target Milestone: --- → 104 Branch

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/4013185a573b
Unload accounts in NntpModuleLoader to prevent nntp-cpp mixed with nntp-js. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Backout by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/5064753a240d
Backed out changeset 4013185a573b for test failures. rs=backout
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
See Also: → 1779413
See Also: 1779413
Attachment #9285038 - Attachment description: Bug 1745033 - Unload accounts in NntpModuleLoader to prevent nntp-cpp mixed with nntp-js. r=mkmelin → Bug 1745033 - Init NntpModuleLoader in AccountManager to prevent nntp-cpp mixed with nntp-jsm. r=mkmelin
Attachment #9285090 - Attachment is obsolete: true

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/34bfbd4843ab
Init NntpModuleLoader in AccountManager to prevent nntp-cpp mixed with nntp-jsm. r=mkmelin

Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Depends on: 1779865

Comment on attachment 9285038 [details]
Bug 1745033 - Init NntpModuleLoader in AccountManager to prevent nntp-cpp mixed with nntp-jsm. r=mkmelin

[Approval Request Comment]
Regression caused by (bug #): bug 1707550
User impact if declined: nntp-js doesn't work due to primary password and permisssions.sqlite
Testing completed (on c-c, etc.): beta
Risk to taking this patch (and alternatives if risky): low

Attachment #9285038 - Flags: approval-comm-esr102?

Still exists in thunderbird 102.1

(In reply to Kamil Jonca from comment #58)

Still exists in thunderbird 102.1

Yes, comment 57 requested to land the patch onto the esr102 branch. Please wait a few more days, thanks.

Comment on attachment 9285038 [details]
Bug 1745033 - Init NntpModuleLoader in AccountManager to prevent nntp-cpp mixed with nntp-jsm. r=mkmelin

[Triage Comment]
Approved for esr102

Attachment #9285038 - Flags: approval-comm-esr91+

Comment on attachment 9285038 [details]
Bug 1745033 - Init NntpModuleLoader in AccountManager to prevent nntp-cpp mixed with nntp-jsm. r=mkmelin

[Triage Comment]
fixing the approval flag

Attachment #9285038 - Flags: approval-comm-esr91+
Attachment #9285038 - Flags: approval-comm-esr102?
Attachment #9285038 - Flags: approval-comm-esr102+

I think I'm seeing this on 102.2.0 (which just got released as a Fedora update). Is that expected?

You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: