Closed Bug 1745147 Opened 7 months ago Closed 2 months ago

Acceptance of a recurrence exception accepts the other non-exception elements of the recurrence

Categories

(Calendar :: Provider: CalDAV, defect)

Thunderbird 91
defect

Tracking

(Not tracked)

RESOLVED FIXED
102 Branch

People

(Reporter: adrien.rybarczyk, Assigned: lasana)

References

(Blocks 1 open bug)

Details

Attachments

(4 files)

Attached image beforeAcceptation.PNG

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/94.0.4606.61 Safari/537.36

Steps to reproduce:

  1. Create a recurrence from another email address and invite yourself to the recurrence
  2. Add a recurrence exception
  3. From the invitation email, accept the invitation for the recurrence exception.

Actual results:

The events accepted will be those of the original recurrence, the recurrence exception will not be in accepted status.

Expected results:

When accepting a recurrence exception, that the status applies to the exception.

Attached image afterAcceptation.PNG
Attached image details.PNG

Another problem with the imip-bar after accepting a recurrence exception is the details button.

If you click on it from the recurrence exception mail, it will display the details of the recurrence itself and not the details of the exception.

This seems to indicate that the exception is not handled as a separate standalone event, but it's kept as part of the recurring event.
Indeed, when an exception to a recurring event is created, that exception should be specially handled and not affect the recurrent event it originally belong to.

Lasana, can you investigate this?

Flags: needinfo?(lasana)
Assignee: nobody → lasana
Flags: needinfo?(lasana)

This seems to only happen for me when using a caldav calendar and not a local one. Specifically, it seems to be happening with invitations automatically added by the server. Are you using a CalDav server? If so, which provider?

Flags: needinfo?(adrien.rybarczyk)

(In reply to Lasana Murray from comment #4)

This seems to only happen for me when using a caldav calendar and not a local one. Specifically, it seems to be happening with invitations automatically added by the server. Are you using a CalDav server? If so, which provider?

Yes, I use a CalDav server. Zimbra provider.

Flags: needinfo?(adrien.rybarczyk)

So far this seems to happen when TB has not yet refreshed the calendar and the user takes action on the email. By that time the server may have already applied changes to the event. Gmail appears to automatically apply minor and major updates even though the participation status is still "NEEDS-ACTION".

Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Blocks: 1759590

I'll add tests for this in bug 1759590. We should not need to mock a caldav server, just adding the event with "NEEDS-ACTION" should do.

Target Milestone: --- → 102 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/ef11e36a3f63
Allow exceptions to be processed when the parent event partStat is "NEEDS-ACTION". r=john.bieling

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.