The window feature "titlebar=yes" will open a popup maximized covering the window taskbar

RESOLVED FIXED

Status

()

Core
DOM: Core & HTML
RESOLVED FIXED
16 years ago
13 years ago

People

(Reporter: Gérard Talbot, Assigned: Dan M)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

16 years ago
If the arguments of a window.open() method are
window.open(url, name, "titlebar=yes")
then the popup window will be maximized and will even cover the window taskbar
despite having 
Start/Settings/Control Panel/Taskbar and Start menu/Taskbar tab/Taskbar
appearance fieldset/Keep the taskbar on top of other windows checkbox checked and 
auto-hide the taskbar checkbox unchecked

If the arguments are
window.open(url, name, "titlebar=yes,resizable=yes")
then the popup window will still be maximized but will NOT cover the window
taskbar. (It appears that screen.availHeight is not respected).
No setting in Edit/Preferences.../Category:Advanced/Scripts & Plugins/Allow
scripts to:/ appears to have an impact on this bug.

This bug happens in XP Pro SP1 with build 2002101015 and under Phoenix 0.3

Actual results: window.open(url, name, "titlebar=yes") maximizes the popup and
covers the window taskbar

Expected results: window.open(url, name, "titlebar=yes") should maximize the
popup but should NOT covers the window taskbar.
Whether some taskbar property settings in Windows should allow to use
screen.height instead of screen.availHeight is also another issue.

I hope to be able to upload 2 auto-related attachments because the url at
geocities will not be optimal, ideally useful with upper top-right corner banners.
(Reporter)

Comment 1

16 years ago
Created attachment 102911 [details]
This is the child popup window

The buttons are auto-related to the parent. (Not sure if this will work in
bugzilla...)

You should use the next attachment which is the parent window making the
window.open() method call.
(Reporter)

Comment 2

16 years ago
Created attachment 102912 [details]
This is the parent window.

This parent window calls the child popup window with the settings, arguments
the user chooses.

Just load this parent window, do not select any checkbox or do not enter any
values in the input and click the create popup button.

I really do not know if this will work on bugzilla.mozilla .

Comment 3

16 years ago
Confirming with build 20021015 on WinXP-SP1.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Updated

16 years ago
Attachment #102911 - Attachment is obsolete: true
(Reporter)

Updated

16 years ago
Attachment #102912 - Attachment is obsolete: true
(Reporter)

Comment 4

16 years ago
I removed the 2 test cases and change the url field to point toward the
meta-testcase I did for the window.open() method. 
(Reporter)

Updated

16 years ago
Blocks: 86194
How about a point-and-click testcase that shows this problem and no other problems?
(Reporter)

Comment 6

16 years ago
Created attachment 112491 [details]
Reduced test case

Any open() calls that does not imply "resizable=yes" nor measurements nor
positions nor chrome nor dialog will generate the same maximized (full-screen)
popup. There's 11! (39916800) different ways to create that same popup
maximized, full-screen even covering the windows taskbar.

e.g.:
window.open('http://www.mozilla.org', 'WindowName',
'titlebar=yes,menubar=yes,directories=yes,toolbar=yes,location=yes,status=yes,scrollbars=yes');

will also create a maximized fullscreen even hovered above the Windows taskbar.
I talked to danm about this, and he agreed to have a look... Reassigning.
Assignee: jst → danm

Comment 8

15 years ago
Same behaviour on Windows 98SE (20030312)
(Reporter)

Comment 9

14 years ago
This bug seems to be fixed also due to the fix in bug 239876. At least, I can
not see the buggy behavior anymore. 1.8a build 2004042909 under XP Pro here.

Therefore, I am RESOLVING this bugfile as FIXED
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 10

14 years ago
Actually this seems to be working even in 1.6, so bug 239876 did not fix this
one, but either way - confirmed fixed.
(Reporter)

Comment 11

14 years ago
Yes, you're right. So, it should have been resolved as WORKSFORME instead. Oh
well...
You need to log in before you can comment on or make changes to this bug.