Closed Bug 174539 Opened 20 years ago Closed 20 years ago

Question marks in title bar

Categories

(Core :: Internationalization, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 9449

People

(Reporter: BugTrap, Assigned: tetsuroy)

References

()

Details

(Keywords: intl)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021014 Phoenix/0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021014 Phoenix/0.3

When accessing websites with foreign character sets (chinese, hebrew, etc.) the
title bar displays question marks instead of the expected title

Reproducible: Always

Steps to Reproduce:
Simply access the sites of Galanz (industrial corporation in China) at
http://www.galanz.com.cn (site in the PROC) 
...or the hebrew version of the Haaretz israeli newpaper at http://www.haaretz.co.il
...or the website of qatari television Al Jazeera at http://www.aljazeera.net

Actual Results:  
Phoenix 0.3 title bar displays question marks instead of the expected (native
language) title.

Expected Results:  
Should display the expected title in each native language, i.e. with the proper
character sets. 
I've tested it (same URLs) with Microsoft Internet Explorer 6.0 SP1 (and I
suspect with less recent versions as well) and it works just fine as expected.
This mean I have the propoer character fonts on my machine.

The web pages of the above-mentioned URLs are correctly displayed, it's just the
browser's title bar that's wrong.
Interestingly, when these URLs are opened in tabs, the tabs titles are displayed
just fine, with the expected characters and fonts. Tested with the three URLs
mentioned.
Summary: Question marks in the windows title bar → Question marks in title bar
This is probably a Mozilla bug. 
Assignee: blaker → yokoyama
Component: General → Internationalization
Product: Phoenix → Browser
QA Contact: asa → ruixu
Version: unspecified → other
Keywords: intl
QA Contact: ruixu → ylong
dup of 9449 which will be fixed by 104934

*** This bug has been marked as a duplicate of 9449 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Mark as verified as dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.