annoying aspects of spell checker (handling hyphenation)

RESOLVED WORKSFORME

Status

P3
normal
RESOLVED WORKSFORME
19 years ago
14 years ago

People

(Reporter: sandilands, Assigned: cmanske)

Tracking

({polish})

Trunk
Future
polish

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Name : Mark Sandilands

Email : sandilands@uleth.ca

Product : Communicator 4.7

OS : Macintosh - PowerPC

1. I like the spell checker in general but there are times that it's frustrating

 and would like to be able to disable it for one particular message, for example

, when I've chosen to forward as inline because I want to edit the quoted materi

al or incorporate it into a message.



2. It is also very frustrating because

it doesn't recognize hyphenated words as, for example, word perfect does and ind

icates that they're misspelled.



3. An easy fix for both of these would be to

make IGNORE the default on the spell checking window (rather than REPLACE) so th

at the users could simple hit <return> when they don't want the spell checker to

 change their message.



4. Can't you offer a Canadian option for a spelling di

ctionary?  Canadian English is different from American or UK English.
*** Bug 17455 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M14
Yes, we have planed to correct most of the points your are mentioning. About a Canadian dictionary, I don't know
what is available today!

Updated

19 years ago
QA Contact: lchiang → pmock

Comment 3

19 years ago
changing qa assigned to pmock@netscape.com

Comment 4

19 years ago
Logged request for enhancement bug 17777 for canadian option.

Updated

19 years ago
Target Milestone: M14 → M17

Comment 5

19 years ago
moving to future.
Keywords: nsbeta3
Target Milestone: M17 → Future

Updated

18 years ago
Keywords: polish

Comment 6

18 years ago
nsbeta3- per mail triage review
Whiteboard: nsbeta3-

Updated

18 years ago
Whiteboard: nsbeta3- → [nsbeta3-]

Updated

18 years ago
Assignee: ducarroz → cmanske
Status: ASSIGNED → NEW
Component: Composition → Editor
Product: MailNews → Browser

Comment 7

18 years ago
moving over to browser, per cmanske
(Assignee)

Comment 8

18 years ago
Some issues already addressed. Hopefully, the current "default key" behavior
will be more to your liking. It tries to compromise between those who prefer
"Change" default vs. "Replace" default. Latter is used only when there is a
suggested word found (first in list).
The hyphenation bug is in the core code that we can't change.
Hopefully, we'll get an open source replacement that we have better control over.

Status: NEW → ASSIGNED
Hardware: Macintosh → All

Comment 9

18 years ago
Changing platform
Hardware: All → Macintosh

Updated

18 years ago
Keywords: nsbeta3
OS: Mac System 8.6 → All
Hardware: Macintosh → All
Whiteboard: [nsbeta3-]

Updated

17 years ago
Component: Editor: Core → Editor: Composer

Comment 10

17 years ago
spam composer change

Updated

17 years ago
Blocks: 119232

Comment 11

16 years ago
which particular issue(s) is this bug left open to track? hyphenation? Canadian
dictionary?
should rods be cc'd?

Comment 12

16 years ago
Here are additional comments from the bug author (sent by e-mail):
>Actually, I've stopped using Netscape for my mail.  I tried it again a couple of
>weeks ago (4.8 -- many sites don't recommend 6 or 7) and found the same problems
>with the spell checker.

This is intended to clarify that this is filed against the Netscape spellchecker
engine and not the mozdev effort (ASpell).
Summary: annoying aspects of spell checker → annoying aspects of spell checker (handling hyphenation)

Comment 13

16 years ago
So where exactly is the spell checker for OSX Mac? I don't see any indicaton of
it anywhere. Where exactly would I find it? It's not listed in any of the
menu's, and I don't see any button, so what am I missing? Running build 2002101009

Thaks!

Comment 15

15 years ago
This issues seem resolved to me. We recognized mispelled pieces of hyphenated word.

Ignore should NOT be the default.

We no longer spellcheck quoted text.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.