If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Customize top toolbar causes "file, edit" etc menu to not work

VERIFIED INVALID

Status

()

Firefox
Toolbars and Customization
VERIFIED INVALID
15 years ago
11 years ago

People

(Reporter: Ben Wills, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021014 Phoenix/0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021014 Phoenix/0.3

When right-mouse clicking the navigation toolbar and choosing the "customize"
option, customizing works.  However, when done adding a button (such as "new
tab"), the file menu is inaccessible.

Reproducible: Always

Steps to Reproduce:
1. right mouse click near the stop button
2. choose customize
3. add a button
4. click done

Actual Results:  
the file menu is inaccessible

Expected Results:  
returned file menu to being accessible

Comment 1

15 years ago
Worksforme with today's builds on linux and win2K. Did you install to a clean
directory and remove your old profile as recommended in the release notes?

Comment 2

15 years ago
*** Bug 174774 has been marked as a duplicate of this bug. ***

Comment 3

15 years ago
I saw this problem too. After moving the whole profile directory the problem
disappears. (Of course I then had to copy over the old bookmarks file, cookies
file, prefs file, and re-customize the toolbars... blah.)

Comment 4

15 years ago
*** Bug 175261 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago
Yes, following the instructions in the release notes fixes this. Not a bug. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 6

15 years ago
Mass-verifying of old bugs.
Status: RESOLVED → VERIFIED

Comment 7

14 years ago
Taking QA Contact
QA Contact: asa → bugzilla

Comment 8

14 years ago
I'm seeing this bug on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a)
Gecko/20040510 Firefox/0.8.0+ with a clean profile. Today's Win32 build works fine.

Steps to Repro:
1a. View | Toolbars | Customize
-or-
1b. Right-click on a toolbar, Customize.
2. Do something (or nothing).
3. Press Done.

Expected Results:
Menus should work okay.

Actual Results:
Menus are disabled until browser is restarted.

I have a feeling this *may* have the same root cause as bug 243210, but I'm not
sure on that.
Status: VERIFIED → UNCONFIRMED
Keywords: regression
OS: Windows 2000 → Linux
Resolution: INVALID → ---

Comment 9

14 years ago
Reassign to default owner/QA, and set to NEW.
Assignee: hyatt → bugs
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 10

14 years ago
(In reply to comment #8)

Same problem here.

checkout finish: Mon May 10 22:28:26 EDT 2004  ... Mozilla/5.0 (X11; U; Linux
i686; en-US; rv:1.8a) Gecko/20040510 Firefox/0.8.0+

Comment 11

14 years ago
Going to close this and file a new bug instead, since the cause is different.
Status: NEW → RESOLVED
Last Resolved: 15 years ago14 years ago
Keywords: regression
OS: Linux → Windows 2000
Resolution: --- → INVALID

Updated

14 years ago
Status: RESOLVED → VERIFIED

Comment 12

14 years ago
(In reply to comment #11)
> Going to close this and file a new bug instead, since the cause is different.

I've filed bug 243262 to address the new regression.

Updated

11 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.