Mozilla using plugger doesn't read pdf files

RESOLVED WORKSFORME

Status

Plugins Graveyard
Plugger
P3
normal
RESOLVED WORKSFORME
15 years ago
2 years ago

People

(Reporter: Leonard Evens, Unassigned)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

We can't get Mozilla to read pdf files reliably.  We've tried this with Mozilla
0.999 and also version 1.1.  When one clicks on a pdf file, Mozilla follows
plugger and starts acroread.  With version 0.999, after acroread comes up, no
file is visible in it.   With version 1.1, it usually works, but sometimes it
doesn't.  Acroread starts, there is the file appears briefly on the screen and
then is replaced by a blank screen with the message below that the plugin is
starting.

When /etc/pluggerrc is modified by putting the line for xpdf before the
one for acroread, both versions of Mozill appear to work properly.

This may also affect other plugins.  One of my colleagues has just removed
the plugger package and adds applications as needed.  It impacts seriously on
the usefulness of Mozilla.  It seems that it may be a problem not specifically
with Mozilla but with how it interacts with plugger.


Reproducible: Always

Steps to Reproduce:
1.click on a pdf file at a web site
2.
3.

Actual Results:  
As noted above, either acroread comes up without any file showing, or after
a brief appearance of the file, the screen goes blank and nothing happens.

Expected Results:  
It should have brought up acroread with the desired file showing.

Comment 1

15 years ago
What version of plugger ? What version of acroread ? What version of xpdf.

I don't see any of the issues mentioned with plugger 4.0, acroread 5.0
and xpdf 1.0.1 and mozilla cvs 20021015 on Linux.
(Reporter)

Comment 2

15 years ago
On one of the machines this was observed on
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827
plugger 4.0-6
Acrobat 4.0
There was no problem with xpdf, but the version was
1.00-3

I will try to install Acrobat 5.0 to see if the problem persists.

Comment 3

15 years ago
==> Plugins
Assignee: asa → beppe
Component: Browser-General → Plug-ins
QA Contact: asa → shrir
If you download that PDF file, can you open it in that version of acroread?
(Reporter)

Comment 5

15 years ago
1.  The problem doesn't seem to arise with Acrobat 5.  

2.  It shows up with Acrobat 4, but only when used as a plugin.  It doesn't
show up if the file is downloaded and acroread is invoked directly.

Comment 6

15 years ago
If you use the current supported version of Acroread it works - correct? If that
is the case, then I would like to mark this bug as WFM in that the current
supported product from Adobe functions correctly.
(Reporter)

Comment 7

15 years ago
As best I can tell, it still doesn't work properly with Acrobat 5.0 and Mozilla
version 0.999, which is what is distributed with RedHat 7.3.  But it does appear
to work with Mozilla 1.1.  I think RedHat hasn't been distributing Mozilla 1.1
because it isn't consistent with some other components of RH 7.3 such a galeon,
but I'm not sure.  I conjecture that there may in fact be an ongoing problem
which is just masked somehow in the latest releases, but I can't prove it.

Comment 8

15 years ago
there is a 5.0.6 release for linux -- can you please try that version if you do
not have that loaded
http://download.adobe.com/pub/adobe/acrobatreader/unix/5.x/linux-506.tar.gz

Comment 9

15 years ago
reassign
Assignee: beppe → peterl

Updated

15 years ago
Severity: major → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Target Milestone: --- → Future
no answer after comment#5
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
Component: Plug-ins → Other
Product: Core → Plugins
QA Contact: shrir → other
Target Milestone: Future → ---
Version: Trunk → unspecified

Updated

8 years ago
Assignee: peterl-bugs → nobody
Component: Other → Plugger
QA Contact: other → plugger
Version: unspecified → 4.x
(Assignee)

Updated

2 years ago
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.