One or more user_pref settings prevents Mac command keys from working correctly

VERIFIED INVALID

Status

SeaMonkey
General
VERIFIED INVALID
15 years ago
12 years ago

People

(Reporter: Vicki Brown, Assigned: asa)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2a) Gecko/20020910
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2a) Gecko/20020910

This was bug 173826; then I discovered that if I remove both my prefs.js file
AND my user.js file from my "profile folder, the problem goes aay. However, it
is not clear to me why ANY of ther prefs I have could cause my Mac command keys
to not work. (e.g. cmd-N for New window, cmd-C for copy, etc)

I am attaching my prefs.js file to this bug report

Reproducible: Always

Steps to Reproduce:
1.
2.
3.




# Mozilla User Preferences
// This is a generated file!

user_pref("browser.blink_allowed", false);
user_pref("browser.block.target_new_window", true);
user_pref("browser.bookmarks.added_static_root", true);
user_pref("browser.cache.disk.capacity", 5000);
user_pref("browser.cache.disk.parent_directory",
"AAAAAAGIAAIAAQRaZWhuAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAC5pV4FSCsAAAADLi0MOWYxZGg2NGYuc2x0AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAMuLrmqtZkAAAAAAAAAAP////8AAAEgAAAAAAAAAAAAAAAAAAAAB2RlZmF1bHQAABAACAAAuaXAdQAAABEACAAAuasYCQAAAAEAGAADLi0AAy4sAAMtigABVckAAUK1AAFCCwACADxaZWhuOlVzZXJzOnZsYjpMaWJyYXJ5Ok1vemlsbGE6UHJvZmlsZXM6ZGVmYXVsdDo5ZjFkaDY0Zi5zbHQADgAaAAwAOQBmADEAZABoADYANABmAC4AcwBsAHQADwAKAAQAWgBlAGgAbgASADdVc2Vycy92bGIvTGlicmFyeS9Nb3ppbGxhL1Byb2ZpbGVzL2RlZmF1bHQvOWYxZGg2NGYuc2x0AAATAAEvAP//AAA=");
user_pref("browser.display.screen_resolution", 96);
user_pref("browser.download.dir",
"AAAAAAFEAAIAAQRaZWhuAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAC5pV4FSCsAAAABQzoJRG93bmxvYWRzAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAFE7rkqSpIALwANAnYBnv////8AAAEgAAAAAAAAAAAAAAAAAAAACURvY3VtZW50cwAAEAAIAAC5pcB1AAAAEQAIAAC5Kq0CAAAAAQAMAAFDOgABQrUAAUILAAIAIlplaG46VXNlcnM6dmxiOkRvY3VtZW50czpEb3dubG9hZHMADgAUAAkARABvAHcAbgBsAG8AYQBkAHMADwAKAAQAWgBlAGgAbgASAB1Vc2Vycy92bGIvRG9jdW1lbnRzL0Rvd25sb2FkcwAAEwABLwD//wAA");
user_pref("browser.helperApps.neverAsk.openFile",
"application%2Fx-stuffit%2C%20application%2Fmac-binhex40%2C%20application%2Fx-gzip");
user_pref("browser.helperApps.neverAsk.saveToDisk", "application%2Foctet-stream");
user_pref("browser.history.last_page_visited",
"http://mozilla.org/quality/help/bug-form.html");
user_pref("browser.history_expire_days", 7);
user_pref("browser.startup.homepage", "http://www.cfcl.com/~vlb");
user_pref("browser.startup.homepage_override.mstone", "rv:1.2a");
user_pref("browser.startup.page", 0);
user_pref("browser.tabs.loadInBackground", true);
user_pref("browser.tabs.opentabfor.middleclick", true);
user_pref("browser.tabs.opentabfor.urlbar", true);
user_pref("browser.toolbars.showbutton.bookmarks", false);
user_pref("browser.toolbars.showbutton.go", true);
user_pref("browser.toolbars.showbutton.print", false);
user_pref("browser.toolbars.showbutton.search", false);
user_pref("browser.urlbar.autocomplete.enabled", false);
user_pref("browser.urlbar.showPopup", false);
user_pref("browser.urlbar.showSearch", false);
user_pref("browser.view_source.syntax_highlight", false);
user_pref("capability.policy.default.Window.open", "noAccess");
user_pref("capability.policy.popupsites.Window.open", "noAccess");
user_pref("capability.policy.popupsites.sites", "http://www.annoyingsite1.com
http://www.popupsite2.com");
user_pref("dom.disable_open_click_delay", 1000);
user_pref("dom.disable_open_during_load", true);
user_pref("dom.disable_window_open_feature.status", true);
user_pref("dom.disable_window_status_change", true);
user_pref("font.default", "sans-serif");
user_pref("font.minimum-size.x-western", 13);
user_pref("font.name.sans-serif.x-western", "Comic Sans MS");
user_pref("font.size.variable.x-western", 12);
user_pref("font.x11.rejectfontpattern", "fname=.*arial.*");
user_pref("image.animation_mode", "once");
user_pref("imageblocker.enable", true);
user_pref("intl.charsetmenu.browser.cache", "windows-1252, UTF-8, ISO-8859-1");
user_pref("ldap_2.prefs_migrated", true);
user_pref("network.cookie.cookieBehavior", 0);
user_pref("network.protocol-handler.external.mailto", true);
user_pref("prefs.converted-to-utf8", true);
user_pref("security.warn_entering_secure", false);
user_pref("security.warn_entering_weak", false);
user_pref("security.warn_leaving_secure", false);
user_pref("security.warn_submit_insecure", false);
user_pref("security.warn_viewing_mixed", false);
user_pref("signon.SignonFileName", "32210318.s");
user_pref("timebomb.first_launch_time", "1032152975000000");
user_pref("ui.key.accelKey", 18);
user_pref("ui.submenuDelay", 7000);
user_pref("ui.textSelectBackground", "green");
user_pref("wallet.SchemaValueFileName", "34211161.w");
user_pref("wallet.caveat", true);
(Reporter)

Comment 1

15 years ago
*** Bug 173826 has been marked as a duplicate of this bug. ***
> user_pref("ui.key.accelKey", 18);

This is the pref to set the accelerator key to "alt" instead of the default (the
default being "command" on Mac).  See
 
http://www.mozilla.org/unix/customizing.html#keys

The pref is editable via the debug panel in preferences if desired....

Comment 3

15 years ago
Reporter: Please confirm that removing:
    user_pref("ui.key.accelKey", 18);
fixes the problem.

If it does, then please close this bug (invalid sounds right).

Comment 4

15 years ago

Vicki, can you confirm/deny Comment 3?

"Reporter: Please confirm that removing:
    user_pref("ui.key.accelKey", 18);
fixes the problem."

Comment 5

15 years ago
Over 7 months and no response from Reporter.

-> INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.