Open Bug 1746395 Opened 7 months ago Updated 4 months ago

TB91 Google's universal contacts birthday-calendar CalDAV URL comes with an 'credentials not accepted' error

Categories

(Calendar :: Provider: CalDAV, defect)

Thunderbird 91
defect

Tracking

(Not tracked)

UNCONFIRMED

People

(Reporter: Software, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:95.0) Gecko/20100101 Firefox/95.0

Steps to reproduce:

Subscribe to the birthday calendar of my Google account.
Note: I'm using the Dutch localized versions, so translations can be different from the English menu-items.

Preparation:

  • In your web-browser look up your Google 'Calendar-ID' (aka calid) which can be found in the online settings menu in Google calendar at: https://calendar.google.com/
    Look for it in the 'Integrate calendar' section.
    (In Dutch: Zoek het Google 'Agenda-ID' op in het online 'Instellingen'-menu van Google agenda, te vinden onder de sectie: 'Agenda integreren'.)
  • Use the URL-syntaxis: https://apidata.googleusercontent.com/caldav/v2/<Calendar-ID>/user
    in which <Calendar-ID> is your Google Calendar-ID in the steps below.
    More information at: https://developers.google.com/calendar/caldav/v2/guide
  • Note: Google's birthday calendars all have the same generic/universal 'Calendar-ID' and therefore URL. They are uniquely identified by the username (Gmail-address) logging in.

Steps in thunderbird for adding the BIRTHDAY calendar:

  1. Create new calendar;
  2. Select 'On the network', next;
  3. Input:
  4. Click: 'Search calendar' and provide your password when asked;

Actual results:

  1. The screen returns with an 'credentials not accepted' error. Not connecting to the birthday calendar.
    (The error in Dutch: 'De ingevoerde referenties werden niet geaccepteerd. Controleer uw instellingen'.)
    Screenshot included.

Expected results:

Connecting my birthday calendar in Thunderbird. This error occurred after upgrading Thunderbird to version 91.x.x in previous versions, maybe even an early version of 91 I had no problem connecting the birthday calendar.
All other (Google) calendars (also using CalDAV) work fine.

What I did/also tried:

  • I removed all my Google calendars and had no issue reconnecting them again. Except for the birthday-calendar.
  • I tried to put the birthday-calendar in read only mode by adding '.readonly' at the end of the URL. See the links provided in the preparation.

PS. I also checked bugs:

  • 1682177 connecting to two birthday calendars;
  • 1735525 connecting to a calendar shared with a Google account in Google itself;
  • 1737414 connecting to a Google calendar using a Google account without Gmail.

Suggestions anyone?

Someone here?

I don't know how this works, but since I'm waiting for over one month now. I'm having a hard head (as we Dutch use to say) in getting any help here at al...
So, third time: Anyone here willing to help?
Or react at all, that would be nice to!

As this is not a support but a bug/feature tracking system, have you tried https://support.mozilla.org/en-US/products/thunderbird to get support for your issue?

I don't remember exactly Martin,

As I mentioned in the bug description back in December: I searched this forum thoroughly back then...
And when I search the support-forum you mentioned here I stumble upon questions like 1352307, 1352226, 1311079 and 1317744. The last question resulting in bug 1682177 led me back here...
So I'm pretty sure I also did search for this bug on the support-forum last December!

Note: I'm using the TBsync and the related provider for CalDAV & CardDAV add-ons, I forgot to mention that earlier.
As I also mentioned in December;: 'All other (Google) calendars (also using CalDAV) work fine'.
And since I'm syncing two Google calendars from two different Google-accounts, I think this is a bug. Especially because I can access the 'normal' Google calendar from the same account I'm trying to connect the contacts/birthday-calendar from whiteout any problem.

**Correction: ** I'm using the TBsync and the related provider for CalDAV & CardDAV add-ons only for syncing my address books. Not for the calendars.
Those are connected using the Thunderbird engine itself. Also turning off all add-ons doesn't make a difference.
That is why I did not mention them before...

Thanks!

Anyone here?

Hello,

Because I got a wall of silence/lack of response here, I posted question 1367925 at the Mozilla forum, where people are more helpful at least.
The solution was quite simple after all. You simply have to add Google calendars without URL (empty location-field) in the new versions of Thunderbird this is the case since version 78.7.1 if I'm correct.
Because of this new behavior, the previous correct URLs apparently became unusable, obsolete or something alike. Thus leading to the trouble I had connecting to the contacts birthday-calendar using Thunderbirds build in CalDAV.

You can argue this is no bug but a human error. Well, on the other side I used these URLs for years without any problem. So who changed this behavior? Considering the fact it occurred after a program-update, the simple solution in new program behavior and the non-communication here, I think I know the answer. But I leave it up to you to decide.

Thanks for non-supporting me, my issue is solved. This bug can be closed!

You need to log in before you can comment on or make changes to this bug.