Prefs: Addressing prefs do not stick.

VERIFIED FIXED in M14

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: laurel, Assigned: chuang)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
None of the addressing preferences appear to stick and are not written to
prefs.js.

1.  Launch messenger.
2.  Edit|Prefs|Mail&News|Addressing.
3.  Make changes to various prefs: radio buttons and checkboxes.
    Confirm OK from prefs dialog.
4.  Go back to prefs dialog and check for your addressing pref changes.
    Result:  nothing stuck.
5.  Look at your prefs.js.
    Result:  no changes were written to the file.
(Reporter)

Updated

19 years ago
QA Contact: lchiang → esther
(Reporter)

Updated

19 years ago
Blocks: 17466

Updated

19 years ago
Target Milestone: M14

Comment 2

19 years ago
This pref pane is not hooked up yet.
Assignee: sspitzer → chuang
Status: ASSIGNED → NEW
re-assign to candice.

candice, the pref window has recently gone through some architecture changes.

see http://www.mozilla.org/xpapps/components/prefwindow.html

for details.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 4

19 years ago
Address book preference is not complete yet.  It needs back end support for 
server based preference string to hook up with the checkboxes.

There a bug in radio button when we have boolean preference and the first radio 
button has the value "true", 2nd radio button is "false".  Once select the2nd 
radio button, you can never change back to the first one.  You can see this bug 
in the Appearence|Colors pane.

I have reversed the two radio button in the addressing pane to make it work.  
Mark it fixed for the radio button.  May need another bug for the check boxes.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 5

19 years ago
Using build 20000209m14 on win98, mac and linux the radio buttons are working 
holding a change.  I have logged a new bug for the backend issue for the check 
boxes (27267).  This is verified for the radio buttons only.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.