Can't open new browser window or help->about window & hang upon exit

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
P3
normal
RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: Andy Stone, Assigned: anthonyd)

Tracking

Trunk
mozilla1.4beta
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PL2:NA])

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
I installed the Java 2 runtime plug in because some site said I needed it. 
When that completed, I upgraded to 1.2a from 1.1.  1.2a came up the installation
time, but no other time.  The rest of the time it would hang on the splash
screen.  I went back to 1.1 & now had the same problem.  I uninstalled that &
reinstalled somewhere else, without success.  But then I realised that it was
probably still grabbing the plugin from the orig loc.  I deleted the entire
original location directory tree & 1.1 is now working.  I'm about to try to
upgrade to 1.2.  I have preserved the bad directory structure in case you want
to see it.  Its < 2meg.  I imagine that you could just copy it into "program
files" then install mozilla somewhere else to reproduce the problem.  Or maybe
just drop the plugin into your plugin directory.

  Of course, maybe this is just a bad plugin.  Do you have timeouts or
keep-alive messages that verify that a plugin has not crashed?  How about a
"safe mode" like the windows startup that lets you interactively start the plugins?

Thanks,
Andy
(Reporter)

Comment 1

16 years ago
Forget about all that plugin stuff.  It still does not work most of the time.  
I also tried searching for "moz" in the registry and deleting everything in 
there.  Another interesting fact is that it always works once upon install 
(when the installer auto-executes mozilla).  But I cannot open another 
navigator window, or run any of the other programs.  When I try it just shows 
the hourglass for a couple of seconds.  I'll check to see if it works once on 
reboot too...

Comment 2

16 years ago
Uh, try installing JRE 1.4.1 from http://www.javasoft.com ?
(Reporter)

Comment 3

16 years ago
Installing JRE 1.4.1 does not help.  I'm downloading the 1.2a sources now.  Do 
you think that they will work with visual c++ 5.0 with all the patches?  If not 
how about the VC++ 6.0 academic edition?

http://www.gopcplus.com/pcplus/product.asp?
lMainCategoryID=39&lCategoryID=42&lProductID=43557

Comment 4

16 years ago
Andy:
can you please set your environment variables to include the following:
SET NSPR_LOG_MODULES=Plugin:5,PluginNPN:5,PluginNPP:5,nsHTTP:5
SET NSPR_LOG_FILE=C:\pluginlog.txt

What you will need to do:
1. exit the browser
2. set the above env variables
3. open the browser and go to the URL that hangs the browser.
4. terminate the browser once is has hung
5. access the pluginlog.txt file and rename it
6. open the browser and attach the copied .txt file to this bug

Do you get a talkback report at all?
What other plug-ins do you have installed?
What version of the browser do you have installed?
DO you have multiple versions of the browser installed?
(Reporter)

Comment 5

16 years ago
Created attachment 103198 [details]
startup log and list of plugins

I don't get a talkback.
The plugin list is attached.
I just installed 1.2b, have tried 1.1,& 1.2a.
I have only 1 version installed (I use control panel remove program, or just
install the new on top of the old).

Here is an update on the behavior:

1. It ALWAYS works just after an install (ie when the install program
auto-starts mozilla).
2. Otherwise it works maybe once a day otherwise (maybe once after a reboot?)
3. It hangs on the splash screen.
4. It also hangs when I try to quit (I have to delete the process in the task
man, or the splash screen won't even come up)
5. In the 2 cases where it does work, (ie install & sometimes on reboot), I
cannot open any other mozilla windows (like file:new window).  It wouldn't even
let me open the help:about window once.  Tabs work though.

Comment 6

16 years ago
hmm, if something makes you feel this is java plugin problem, try to rename 
C:\Program Files\Java just call it _Java, then try to repro the hang.
This also could be some kind of graphic card driver problem, see bug 166244.
(Reporter)

Comment 7

16 years ago
Ok, I've bought vc version 6, recompiled the latest source and reproduced the
bug.  I haven't worked on debugging it yet, but some interesting messages
appeared on the console & so I'd like to post them here for your comments:

[Starting up...]
*** Registering -chat handler.
*** Registering x-application-irc handler.
*** Registering irc protocol handler.
*** Registering mdn account manager extension.
*** Deferring registration of sample JS components
*** Registering -venkman handler.
*** Registering x-jsd protocol handler.
nNCL: registering deferred (0)
nNCL: registering deferred (0)
*** Registering sample JS components
nNCL: registering deferred (0)
nsNativeComponentLoader: autoregistering begins.
nsNativeComponentLoader: autoregistering succeeded
nNCL: registering deferred (0)
WARNING: chrome: failed to get base url for
chrome://chatzilla/skin/chatzillaOverlay.css -- using wacky default, file
c:/mozilla/rdf/chrome/src/nsChromeRegistry.cpp, line 562
Error reading file C:\mozilla\dist\bin\chrome\skins\classic\chatzillaOverlay.css
WARNING: CSSLoaderImpl::DidLoadStyle: Load of URL
'chrome://chatzilla/skin/chatzillaOverlay.css' failed.  Error code: 18, file
c:/mozilla/content/html/style/src/nsCSSLoader.cpp, line 1274
WEBSHELL+ = 3
Start reading in bookmarks.html
Finished reading in bookmarks.html  (187000 microseconds)
Document http://www.mozilla.org/start/ loaded successfully
WEBSHELL+ = 4
WARNING: chrome: failed to get base url for
chrome://chatzilla/skin/chatzillaOverlay.css -- using wacky default, file
c:/mozilla/rdf/chrome/src/nsChromeRegistry.cpp, line 562
WARNING: CSSLoaderImpl::LoadAgentSheet: Load of URL
'chrome://chatzilla/skin/chatzillaOverlay.css' failed.  Error code: 18, file
c:/mozilla/content/html/style/src/nsCSSLoader.cpp, line 1955
WEBSHELL+ = 5
WARNING: chrome: failed to get base url for
chrome://chatzilla/skin/chatzillaOverlay.css -- using wacky default, file
c:/mozilla/rdf/chrome/src/nsChromeRegistry.cpp, line 562
WARNING: CSSLoaderImpl::LoadAgentSheet: Load of URL
'chrome://chatzilla/skin/chatzillaOverlay.css' failed.  Error code: 18, file
c:/mozilla/content/html/style/src/nsCSSLoader.cpp, line 1955


[Doing help:aboutmozilla]
WEBSHELL+ = 6
WARNING: chrome: failed to get base url for
chrome://chatzilla/skin/chatzillaOverlay.css -- using wacky default, file
c:/mozilla/rdf/chrome/src/nsChromeRegistry.cpp, line 562
WARNING: CSSLoaderImpl::LoadAgentSheet: Load of URL
'chrome://chatzilla/skin/chatzillaOverlay.css' failed.  Error code: 18, file
c:/mozilla/content/html/style/src/nsCSSLoader.cpp, line 1955

[doing help:about plugins]

Document about:plugins loaded successfully [doing help: release notes]
Document http://www.mozilla.org/releases/ loaded successfully
WEBSHELL+ = 7
WEBSHELL+ = 8
nsNativeComponentLoader: autoregistering begins.
nsNativeComponentLoader: autoregistering succeeded
nNCL: registering deferred (0)
JavaScript strict warning: 
chrome://help/content/help.js line 245: assignment to undeclared variable tocDS

Document http://www.mozilla.org/releases/ loaded successfully

Document http://www.mozilla.org/releases/ loaded successfully
Document about:plugins loaded successfully
Document about:plugins loaded successfully [doing help: release notes]
WEBSHELL- = 7
WEBSHELL- = 6


[doing window: main & newsgroups]
WEBSHELL+ = 7
WARNING: chrome: failed to get base url for
chrome://chatzilla/skin/chatzillaOverlay.css -- using wacky default, file
c:/mozilla/rdf/chrome/src/nsChromeRegistry.cpp, line 562
WARNING: CSSLoaderImpl::LoadAgentSheet: Load of URL
'chrome://chatzilla/skin/chatzillaOverlay.css' failed.  Error code: 18, file
c:/mozilla/content/html/style/src/nsCSSLoader.cpp, line 1955

[Quitting]

WARNING: NS_ENSURE_TRUE(mDocument) failed, file
c:/mozilla/content/base/src/nsDocumentViewer.cpp, line 1184
WEBSHELL- = 6
WEBSHELL- = 5

[Accidently stopped debugging ...]


[RUN # 2 -- start & then quit]

Type Manifest File: C:\mozilla\dist\bin\components\xpti.dat
+++ JavaScript debugging hooks installed.
nsNativeComponentLoader: autoregistering begins.
nsNativeComponentLoader: autoregistering succeeded
nNCL: registering deferred (0)
nsNativeComponentLoader: autoregistering begins.
nsNativeComponentLoader: autoregistering succeeded
nNCL: registering deferred (0)
WEBSHELL+ = 1
WEBSHELL+ = 2
Note: verifyreflow is disabled
Note: styleverifytree is disabled
Note: frameverifytree is disabled
WARNING: chrome: failed to get base url for chrome://chatzilla/skin/chatzillaOve
rlay.css -- using wacky default, file c:/mozilla/rdf/chrome/src/nsChromeRegistry
.cpp, line 562
Error reading file C:\mozilla\dist\bin\chrome\skins\classic\chatzillaOverlay.css

WARNING: CSSLoaderImpl::DidLoadStyle: Load of URL 'chrome://chatzilla/skin/chatz
illaOverlay.css' failed.  Error code: 18, file c:/mozilla/content/html/style/src
/nsCSSLoader.cpp, line 1274
WEBSHELL+ = 3
Start reading in bookmarks.html
Finished reading in bookmarks.html  (156000 microseconds)
Document http://www.mozilla.org/start/ loaded successfully
WARNING: requested removal of nonexistent window
, file c:/mozilla/embedding/components/windowwatcher/src/nsWindowWatcher.cpp, li
ne 929
WEBSHELL- = 2
WEBSHELL- = 1
### nsCacheProfilePrefObserver::Observe [topic=xpcom-shutdown data=]
nsPluginHostImpl::Observe "xpcom-shutdown"
WEBSHELL- = 0
WARNING: nsExceptionService ignoring thread destruction after shutdown, file c:/
mozilla/xpcom/base/nsExceptionService.cpp, line 191
nsPluginHostImpl dtor
###!!! ASSERTION: Component Manager being held past XPCOM shutdown.: 'cnt == 0',
 file c:/mozilla/xpcom/build/nsXPComInit.cpp, line 766
Break: at file c:/mozilla/xpcom/build/nsXPComInit.cpp, line 766


--------------------------------


Since I am pretty new at debugging mozilla (I did 1 week stint about 3 years ago
& fixed 2 or 3 bugs) you may know better than I what information will help me
find this problem.  So feel free to say anything that may be helpful.  The
following questions are I what I can think might help me debug this:

1.  Where is chatzillaOverlay.css supposed to come from (I want to ensure it is
located in the correct place on my machine)?
2.  Where does the chrome registry come from, ie what file holds the registry &
what C file does the loading?
3.  The "using wacky default" stuff: is that just old code from before the
chrome registry & is not supposed to happen, or is the "wacky default" an
acceptable code path?

Thanks,
Andy
Summary: plug in causes hang at splash screen → Cant open new browser window or help->about window & hang upon exit

Comment 8

16 years ago
Assigning to ANthony for debugging assitance
Assignee: beppe → anthonyd
Priority: -- → P3
Whiteboard: [PL2:NA]
Target Milestone: --- → mozilla1.4beta

Comment 9

16 years ago
reporter (Andy): can you reproduce this bug with a recent build of mozilla? if
so, please comment again with details. if not, please resolve this bug as
WORKSFORME. thanks.

Comment 10

16 years ago
Reporter, if you are still crashing, please follow these steps:

1. Download a copy of Mozilla 1.2.1
2. Control Panel | Remove Mozilla (uninstall your current Mozilla)
3. Delete program files\mozilla.org directory (wipe it out) (optional: save the
plugins subdirectory and delete the rest)
4. Install Mozilla 1.2.1

If you do all that, is your problem fixed? 
Summary: Cant open new browser window or help->about window & hang upon exit → Can't open new browser window or help->about window & hang upon exit
(Reporter)

Comment 11

16 years ago
If I delete xul.mfl then it works.  I have a few of the old xul.mfl files, if
you want to see one, I can put it on the web somewhere... is there any reason I
wouldn't want to put it up (such as it holding passwords, etc)?
no dupe in a while, works now for previous comment
btw: xul.mfl doesn't contain any passwords
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
no dupe in a while, works now per previous comment
btw: xul.mfl doesn't contain any passwords
You need to log in before you can comment on or make changes to this bug.