Closed Bug 1746674 Opened 2 years ago Closed 2 years ago

[wpt-sync] Sync PR 32132 - [LayoutNG] OOF in nested multicol with spanner CB paint offset

Categories

(Core :: Layout, task, P4)

task

Tracking

()

RESOLVED FIXED
98 Branch
Tracking Status
firefox98 --- fixed

People

(Reporter: wpt-sync, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [wptsync downstream])

Sync web-platform-tests PR 32132 into mozilla-central (this bug is closed when the sync is complete).

PR: https://github.com/web-platform-tests/wpt/pull/32132
Details from upstream follow.

Alison Maher <almaher@microsoft.com> wrote:

[LayoutNG] OOF in nested multicol with spanner CB paint offset

As a result of CL:3343283, when an OOF has a spanner CB (or a CB
inside a spanner) it will get laid out in the next outer fragmentainer
(if there is one).

The OOF offset in this case is correct at layout, but the offset
would get shifted by the incorrect fragmentainer offset (i.e. by the
inner fragmentainer offset rather than the outer).

The reason being that when we hit a spanner during prepaint, we update
the current fragmentainer to the outer fragmentainer. Because of this,
we will successfully find the OOF during fragment traversal.

The problem is that paint_offset_for_oof_in_fragmentainer does not
also get updated to match the outer fragmentainer. This CL fixes
this by also updating paint_offset_for_oof_in_fragmentainer when
we hit a spanner to ensure the OOF is adjusted by the correct offset.

Bug: 1280662
Change-Id: I4d9dea6804022a56dec6b132a77985432d952dca
Reviewed-on: https://chromium-review.googlesource.com/3348080
WPT-Export-Revision: 82eb05703e074aca9e8b648e919ad94bc4302ee7

Component: web-platform-tests → Layout
Product: Testing → Core

CI Results

Ran 11 Firefox configurations based on mozilla-central, and Firefox, Chrome, and Safari on GitHub CI

Total 4 tests

Status Summary

Firefox

PASS: 2
FAIL: 2

Chrome

PASS: 2
FAIL: 2

Safari

PASS: 4

Links

Gecko CI (Treeherder)
GitHub PR Head
GitHub PR Base

Details

Firefox-only Failures

/css/css-break/out-of-flow-in-multicolumn-078.html: FAIL

New Tests That Don't Pass

/css/css-break/out-of-flow-in-multicolumn-078.html: FAIL (Chrome: PASS, Safari: PASS)
/css/css-break/out-of-flow-in-multicolumn-080.html: FAIL (Chrome: FAIL, Safari: PASS)

Pushed by wptsync@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c54e934a40f9
[wpt PR 32132] - [LayoutNG] OOF in nested multicol with spanner CB paint offset, a=testonly
https://hg.mozilla.org/integration/autoland/rev/aa1c75cac032
[wpt PR 32132] - Update wpt metadata, a=testonly
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 98 Branch
You need to log in before you can comment on or make changes to this bug.