Closed Bug 1746749 Opened 8 months ago Closed 8 months ago

Make feed reader more tolerant to XML errors

Categories

(MailNews Core :: Feed Reader, enhancement)

enhancement

Tracking

(Not tracked)

VERIFIED WONTFIX

People

(Reporter: rachel, Unassigned)

References

()

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:91.0) Gecko/20100101 Firefox/91.0

Steps to reproduce:

Some feeds deliver invalid XML, like <title>Bad & incorrect</title>.
As an effect, the feed may be in error for weeks until the publisher removes the faulty article. It would be good to make the feed reader more tolerant to bad XML.

Some technical detail:
The error console shows:
XML Parsing Error: not well-formed
Location: http://www. [snip]
Line Number 196, Column 24:
feeds: downloaded: updates disabled due to error, check the url - http://www. [snip] FeedUtils.jsm:1957:27

Apparently this is due to a request with type "text/xml" here:
https://searchfox.org/comm-central/rev/2d37ff5988a241647ba8f7da7fc966d8b9ad727c/mailnews/extensions/newsblog/Feed.jsm#188

Sorry I don't think that's reasonable. Feeds are, and have always bee XML. The feed authors need to fix their stuff and not push such things all the consumers.

Status: UNCONFIRMED → RESOLVED
Closed: 8 months ago
Resolution: --- → WONTFIX

+1

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.