Closed Bug 1746804 Opened 8 months ago Closed 7 months ago

Stop clearing browser.ctrlTab.recentlyUsedOrder when migrating the pref (was: browser.ctrlTab.sortByRecentlyUsed set to false when upgrading from esr78 to esr91)

Categories

(Firefox :: Tabbed Browser, defect)

defect

Tracking

()

RESOLVED FIXED
97 Branch
Tracking Status
firefox-esr91 --- wontfix
firefox95 --- unaffected
firefox96 --- unaffected
firefox97 --- unaffected

People

(Reporter: glandium, Assigned: dao)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

With bug 1692303 and bug 1701542, browser.ctrlTab.recentlyUsedOrder was renamed and flipped to false,, except if ctrl-tab was detected as having been used... through a pref that was added in bug 1687703, which landed in 86. So people who were using ctrl-tab in esr78, and then upgraded to the next esr (i.e. esr91), see the pref reset because they had no occasion for the browser.engagement.ctrlTab.has-used pref to be set.

The severity field is not set for this bug.
:dao, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(dao+bmo)

bigiri, can you look into this? It looks like the migration code (needlessly?) clears the old pref, so at this point I guess there's no way to remedy this with an update for users already on ESR91?

Severity: -- → S3
Flags: needinfo?(dao+bmo) → needinfo?(bigiri)
Keywords: regression
Regressed by: 1692303
Has Regression Range: --- → yes

Unfortunately ESR78 is no longer supported. We missed this detail when the patch was merged and there's not much we can do about it. I spoke with @mconley and he suggests that I mark this as "won't fix." If you have more questions Mike says that he will take those, so please direct further questions to him. Thank you.

Status: NEW → RESOLVED
Closed: 7 months ago
Flags: needinfo?(bigiri)
Resolution: --- → WONTFIX

I'm reopening this in order to remove the pref clearing, if only to prevent this pattern from being copied by future migration code.

Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Assignee: nobody → dao+bmo
Summary: browser.ctrlTab.sortByRecentlyUsed set to false when upgrading from esr78 to esr91 → Stop clearing browser.ctrlTab.recentlyUsedOrder when migrating the pref (was: browser.ctrlTab.sortByRecentlyUsed set to false when upgrading from esr78 to esr91)
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0d09faf561bb
When migrating browser.ctrlTab.recentlyUsedOrder, stop clearing it so there's a backup in case of wrongful migration. r=mconley
Status: REOPENED → RESOLVED
Closed: 7 months ago7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 97 Branch
You need to log in before you can comment on or make changes to this bug.