Automatically filtered messages are marked as deleted, but marked as undeleted when the trash folder is upened

VERIFIED DUPLICATE of bug 174676

Status

MailNews Core
Filters
VERIFIED DUPLICATE of bug 174676
15 years ago
10 years ago

People

(Reporter: David K, Assigned: Navin Gupta)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2a) Gecko/20020910
Build Identifier: Mozilla 1.2a

When my spam filters automatically move a spam message to the trash folder the
spam is marked as deleted.  When I open the trash folder in mozilla 1.2a the
automatically moved messages are marked as unread and highlighted in bold text.

Reproducible: Always

Steps to Reproduce:
1. Set up spam filters
2. Have a message automatically filtered to trash (delete)
3. Open the trash folder
Actual Results:  
Automatically filtered messages are marked as unread

Expected Results:  
Automatically filtered messages should not be marked as unread

My filter list is about five pages long, deleting by title and message
content.  I'm not doing anything extrordinary with the capability.  Please
email dakelk@gta.igs.net for any additional followup you may require.

*** This bug has been marked as a duplicate of 174676 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
marking verified as a duplicate
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.