Closed Bug 1747164 Opened 3 years ago Closed 2 years ago

TextLeafPoint::GetTextAttributesLocalAcc fails with date/time input leafs

Categories

(Core :: Disability Access APIs, defect)

defect

Tracking

()

RESOLVED FIXED
97 Branch
Tracking Status
firefox97 --- fixed

People

(Reporter: eeejay, Assigned: eeejay)

References

Details

Attachments

(1 file)

I would like that to be true, but take the following example:
data:text/html,<input type="date">

The HTMLDateTimeAccessible is not a hypertext accessible subclass and it has children that are text leafs (like "/" in the US locale).

I guess the right solution is to make HTMLDateTimeAccessible subclass HyperTextAccessibleWrap?

I think that's the correct solution, yes. That would explain bug 1744150.

Alternatively, we could just fail gracefully for attributes on those text leaves, which is what I was considering for bug 1744150... but that doesn't seem ideal if we know the cause.

Blocks: 1744150

S4 because behind a disabled pref.

Severity: -- → S4
Blocks: 1747835
Summary: TextLeafPoint::GetTextAttributesLocalAcc assumes all text leafs have hypertext parents → TextLeafPoint::GetTextAttributesLocalAcc fails with date/time input leafs
Assignee: nobody → eitan
Status: NEW → ASSIGNED
Pushed by eisaacson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9081d06a622b
Make HTMLDateTimeAccessible inherit from HyperTextAccessibleWrap. r=morgan
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 97 Branch
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: