Extremely slow window resizing

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
VERIFIED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Dave Fennell, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({perf})

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021015
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021015

When in the mail/news browser moving the horizontal and/or vertical section
dividers to resize the panels has a *really* slow refresh.  It also uses 100%
CPU on my machine (A Duron 650 with 133Mhz RAM) 

Reproducible: Always

Steps to Reproduce:
Resize the preview pane up or down.
Or.
Resize the preview pane left or right.

Actual Results:  
The window resizes but uses 100% CPU and updates the screen very very slowely
(maybe 2 frames a second).

Expected Results:  
Smoothly resized...The same way as the scrolling is nice and smooth.

Generally speaking my machine is quite fast.  I am pretty sure this is nothing
to do with my hardware, however the problem does seem slightly worse since I
installed the latest NVidia drivers (30.82).  Here is a list of things which
might be relevant about my machine:

Windows 2000 SP3
DirectX 8.1
NVidia TNT2 Graphics card (Driver version 30.82)
AMD Duron 650Mhz Processor
CAS2 133Mhz SDRAM.
ATA 100 Hard Drive.
(Reporter)

Comment 1

15 years ago
Created attachment 103039 [details]
Vertical Resize - CPU Usage before

This is a screen shot of the CPU usage before vertical resizing.
(Reporter)

Comment 2

15 years ago
Created attachment 103040 [details]
Vertical Resize - CPU Usage After/During

This is the CPU Usage after and during the resize.  The first Spike is when I
pasted the pre screenshot, the second spike is the mail/news browser redrawing
itself after I gave it focus back and the rest is the resizing between where it
was and where it is in this shot.
(Reporter)

Comment 3

15 years ago
Created attachment 103041 [details]
Horizontal Resize - CPU Usage before

This is a screen shot of the CPU usage before horizontal resizing.
(Reporter)

Comment 4

15 years ago
Created attachment 103042 [details]
Horizontal Resize - CPU Usage After/During

This is the CPU Usage after and during the resize.  The first Spike is when I
pasted the pre screenshot, the second spike is the mail/news browser redrawing
itself after I gave it focus back and the rest is the resizing between where it

was and where it is in this shot.
(Reporter)

Comment 5

15 years ago
I am aware that CPU usage is not directly related to how smooth the screen
updates, but I could not think of any other way of showing what is happening!

If the screen were refreshing very fast (like when you resize an explorer
window)(Not internet explorer, I mean explorer ... explorer) then the CPU usage
would probably be 100% too...But that's acceptable then because the output is nice.

Can I suggest that a good way to fix this (at least temporarily until improved
resizing can be done) would be to look at the "show window contents while
dragging" general system setting?  Or if this is not cross platform enough, add
a menu option to do the same thing.  When this option is not set you would only
show a little dotted line or something while resizing and then actually resize
when the position is set (by letting go of the mouse) ?

I know this is a complicated subject and there are lots of things involved, but
one of the main reasons I feel that Mozillas resizing is not doing itself any
justice is the fact that the scrolling is so fast and smooth.  If you resize a
window vertically how different can that be from scrolling it down a bit really?
Surely a lot of the same optimisations apply?  Find the guy (or girl) who wrote
the scrolling and get them to look at this problem!

Updated

15 years ago
URL: N/A
Keywords: perf
(Reporter)

Comment 6

15 years ago
I do suspect this has more to do with Windows 2000 Service Pack 3 than anything,
but there still may be something that could be done to improve the situation, as
the problem seems particularly pronounced in mozilla.
(Reporter)

Comment 7

15 years ago
I decided to uninstall the latest NVidia drivers... When I restarted (which was
forced) the preformance of the default W2K driver was infinately better than
what I had with the latest NVidia one, unfortunately it didn't really support 3D
so I've installed the oldest NVidia driver I still have and it is slightly worse
but still a hell of a lot better than it was.

I'm sorry to have suggested that Mozilla was at fault, the resizing of browsers
is now lovely and although the mail/new resizing is still slightly sluggish it
is acceptably fast.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

15 years ago
P.s. I will be sending a very nasty email to NVidia...

Comment 9

15 years ago
marking verified worksforme
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.