Crashes after right click on empty popup window

VERIFIED DUPLICATE of bug 174448

Status

SeaMonkey
General
--
critical
VERIFIED DUPLICATE of bug 174448
16 years ago
13 years ago

People

(Reporter: Andrei Leo, Assigned: asa)

Tracking

({crash})

Trunk
x86
Windows 2000
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
moz 20021015, Win2K

TB12631843Q
TB12631853M
TB12631933M
TB12631988Y

Steps to reproduce:

1. Go to URL. 
2. Click on one of the photos ( this will open a popup window )
3. Right click in new popup window.

If you are fast enough you will get crush, if not - there are still problems to
check out:
 - Mozilla becomes very slow and responses on clicking with very long delay.
 - after closing all windows mozilla still remains in memory
 - starting new mozilla brings ap profile selection dialog 

need to kill mozilla in Task Manager to make it work again.

This is the code that opens new window on this site:

function openNew (dx,dy,a)
{
WO = window.open('','',"width="+ dx+"
,height="+dy+",toolbar=0,menubar=0,scrollbars=0,resizable=1,status=0,location=0");
var X=dx+10;
var Y=dy+30;
WO.resizeTo (X, Y);
WO.document.write("<div style=\"position:absolute;top:0;left:0;\"><img
src=\"/images/"+a+"\" width="+dx+" height="+dy+"></div>");
WO.focus();
}

Updated

16 years ago
Severity: normal → critical

Updated

16 years ago
Keywords: crash, stackwanted
confirmed. Win2k. 2002121015.

TB12634556E
Whiteboard: TB12634556E

Comment 2

16 years ago
Dupe of 174448.

Product ID  MozillaTrunk
Build ID 2002101015
Operating System Windows NT 5.0 build 2195
URL visited www.riemenschneider-gymnasium.de

Stack Trace
nsMenuPopupFrame::GetRootViewForPopup
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsMenuPopupFrame.cpp, line 516]
nsMenuPopupFrame::AdjustClientXYForNestedDocuments
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsMenuPopupFrame.cpp, line 629]
nsMenuPopupFrame::SyncViewWithFrame
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsMenuPopupFrame.cpp, line 992]
nsPopupSetFrame::RepositionPopup
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsPopupSetFrame.cpp, line 341]
nsPopupSetFrame::DoLayout
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsPopupSetFrame.cpp, line 234]
nsBox::Layout [c:/builds/seamonkey/mozilla/layout/xul/base/src/nsBox.cpp, line 1066]
nsSprocketLayout::Layout
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsSprocketLayout.cpp, line 529]
nsContainerBox::DoLayout
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsContainerBox.cpp, line 609]
nsBox::Layout [c:/builds/seamonkey/mozilla/layout/xul/base/src/nsBox.cpp, line 1066]
nsStackLayout::Layout
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsStackLayout.cpp, line 331]
nsContainerBox::DoLayout
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsContainerBox.cpp, line 609]
nsBox::Layout [c:/builds/seamonkey/mozilla/layout/xul/base/src/nsBox.cpp, line 1066]
nsBoxFrame::Reflow
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsBoxFrame.cpp, line 900]
nsRootBoxFrame::Reflow
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsRootBoxFrame.cpp, line 242]
nsContainerFrame::ReflowChild
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 949]
ViewportFrame::Reflow
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsViewportFrame.cpp, line 579]
IncrementalReflow::Dispatch
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 896]
PresShell::ProcessReflowCommands
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6486]
ReflowEvent::HandleEvent
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6331]
PL_HandleEvent [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c, line 645]
PL_ProcessPendingEvents [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c,
line 578]
_md_EventReceiverProc [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c, line
1336]
nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp, line 472]
main1 [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1538]
main [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1886]
WinMain [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1906]
WinMainCRTStartup()
KERNEL32.DLL + 0x1ca90 (0x77e8ca90) 

*** This bug has been marked as a duplicate of 174448 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Keywords: stackwanted
Resolution: --- → DUPLICATE
Whiteboard: TB12634556E
v - Thanks greer !
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.