If '{' is used in a link it is reformatted to %7B and '}' to %7D

VERIFIED WONTFIX

Status

SeaMonkey
Composer
VERIFIED WONTFIX
15 years ago
13 years ago

People

(Reporter: Jeff Bristow, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020826

If in a link you use a link such as this {U_PRIVMSSGS} it will turn into this
when you save the file 7%BPRIVMSSGS7%D , and this is with reformatting HTML off.
The code gets reformatted anyway. This bug can wreck havoc on pages where you
are using PHP and HTML, when reformatting is off it should truly be off. I don't
want the editor trying to correct my code because I have yet to meet an editor
that is smart enough to not screw it all up.

Reproducible: Always

Steps to Reproduce:
1.Open up Composer
2.Make a page with a link to {U_Priv}
3.Save the file
4.Close Composer
5.Open Composer and the file you created
6.The link will now be 7%BU_Priv7$D
Actual Results:  
{U_Priv} turned into 7%BU_Priv7%D

Expected Results:  
Make it so nothing is reformatted when reformatting is turned off, not even
strange characters because PHP needs some of these characters to process the
page correctly.

Comment 1

15 years ago
fixing urls has nothing to do with reformatting of html

{ and } are properly escaped to %7B and %7D

If I recall correctly, he escaping is part of the URI specification/standard so
there are no plans to fix this "correction"; uri's are not supposed to have
certain characters in them.

-->wontfix
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
OS: Linux → All
Hardware: PC → All
Resolution: --- → WONTFIX
Summary: If a { is used as a link it is reformatted to 7%B and the } is 7%D - with reformatting turned off → If '{' is used in a link it is reformatted to %7B and '}' to %7D

Comment 2

15 years ago
verified.
Status: RESOLVED → VERIFIED

Comment 3

15 years ago
reset owner in case bugs are reopened
Assignee: syd → composer
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.