URL context for acroread plugin not right, breaks links between pdf docs

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
15 years ago
15 years ago

People

(Reporter: John Ellson, Assigned: rubydoo123)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021009
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021009

Links between pdf docs worked OK in Netscape 4 using the Adobe acroread plugin,
but in Mozilla a link such as "cd_a1/etsi_eg/202100_202199/eg_202106v010101p.pdf"
doesn't work.  The plugin complains "no such file or directory".

Note that the href is relative to the URL of the current pdf document, which in
this case was: http://etsi.mirror.lucent.com/eds0207cda1/etsica1.pdf

I think the problem is probably that the current context
(http://etsi.mirror.lucent.com/eds0207cda1/)
is not properly available to the plugin for it to form the full URL
of the linked page.



Reproducible: Always

Steps to Reproduce:
1.Open a pdf document containing relative links in the acroread plugin
2.click on a link to another pdf file
3.

Actual Results:  
file not found

Expected Results:  
clicking on a hyperlink in a PDF document should work
(Assignee)

Comment 1

15 years ago
unable to access the url, can you supply an url that can be accessed?
(Reporter)

Comment 2

15 years ago
Never mind.   It works for me now.

Either its been fixed or I was all screwed up when I wrote the report.

Mozilla 1.2b

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021017
(Assignee)

Comment 3

15 years ago
great news -- marking as wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.