Autodetct charset does not work correctly with meta content tag

VERIFIED WORKSFORME

Status

()

--
minor
VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: toto, Assigned: shanjian)

Tracking

({intl})

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
How to reproduce:
1. Set View->Character coding-> Autodetect to Russian.
2. goto url above
3. After the page loads, watch how View->Character coding is set by Mozilla to     "Cyrillic ISO-8859-5"
 (or if you know russian, watch that the page is rendered in incorrect encoding).
4. Right click on webpage -> View page source and find the tag 
   <meta http-equiv="content-type" content="text/html; charset=UTF-8">,
   so the page must be autodected as utf-8.
Reproducible: always.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826
on windows 2000 rus + sp3.
I think page was loading ok with mozilla 1.0, but i am not sure.
(Reporter)

Updated

16 years ago
With autodetect set to "Russian", the page detected as UTF-8 (I had to change
the "interface language" setting to "russian" in Google preferences to test this
properly).

This is with Linux trunk build 2002-10-14-08.
Assignee: asa → yokoyama
Component: Browser-General → Internationalization
QA Contact: asa → ruixu
Autodetector issue to shanjian.
Assignee: yokoyama → shanjian

Updated

16 years ago
Keywords: intl
QA Contact: ruixu → ylong

Comment 3

16 years ago
Works for me with any auto-detection on http://www.google.com has meta-tag
charset=utf-8.
(Reporter)

Comment 4

16 years ago
The source of bug is www-proxy-server (Proxomitron) thru which i must access www.
Works for me.
(Reporter)

Comment 5

16 years ago
Strange, but internet explorer works ok with or with out Proxomitron proxy.
(Reporter)

Comment 6

16 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021030
Finally works for me. Closing the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 7

16 years ago
Mark as verified per comment above.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.