Closed Bug 1748860 Opened 1 year ago Closed 1 year ago

Upload latest visual metrics dependencies to https://pypi.pub.build.mozilla.org/pub/

Categories

(Release Engineering :: General, task)

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: davehunt, Assigned: jmaher)

References

Details

Please upload the following packages to https://pypi.pub.build.mozilla.org/pub/

These are required to support the Apple Silicon platform, so it's important that the packages uploaded include macosx arm64 binaries.

Use the guidance found here: https://wiki.mozilla.org/ReleaseEngineering/How_To/Upload_to_internal_Pypi

I uploaded these, can we confirm things are working? If you point me at a job then I can retrigger and self fix until all packages are uploaded

Assignee: nobody → jmaher
Flags: needinfo?(dave.hunt)

(In reply to Joel Maher ( :jmaher ) (UTC -0800) from comment #1)

I uploaded these, can we confirm things are working? If you point me at a job then I can retrigger and self fix until all packages are uploaded

There's no job yet, I'll need to submit a patch updating the versions in https://searchfox.org/mozilla-central/rev/6b4e19ad33650fdf9cd8529cd68eeb98bff1b935/testing/mozharness/mozharness/mozilla/testing/raptor.py#1022. I have successfully tested locally, but it appears that you have only uploaded macOS specific packages. Could you also upload packages for Windows and Linux? Sorry for not making it clear that this was for all platforms.

Flags: needinfo?(dave.hunt) → needinfo?(jmaher)

I'd be happy to provide the patch with a try run that you can retrigger and fix as suggested. I'll work on this tomorrow morning.

linux and windows both run python 3.6.9

numpy only has packages for 3.9 and 3.10
pillow/scipy have support for 3.7+

We will need older versions of the libraries in order to upgrade on linux/windows.

Flags: needinfo?(jmaher)

It sounds like we'll need to block this on Python 3.7 being available on Windows and Linux in CI. We may be able to use numpy 1.21.5, which supports python 3.7+. Is there a bug on file for updating Python on these platforms? Note that it's not a priority to support Apple Silicon, it's just that happens to be what I'm using. I'm now able to run visual metrics tests locally with a small patch applied locally.

Flags: needinfo?(jmaher)

can we not special case the dependencies for py39 or osx11+?

there is no bug nor any plans to upgrade python on our moonshots. Ideally we would do this:

  1. upgrade moonshots (i.e. this isn't a priority, probably won't happen in January, maybe end of Q1)
  2. install windows 11 (not win 10 v1803 as currently is there) - which should have python 3.9
  3. install linux 22.04 (vs linux 18.04) - which should have a more modern python
Flags: needinfo?(jmaher)

(In reply to Joel Maher ( :jmaher ) (UTC -0800) from comment #6)

can we not special case the dependencies for py39 or osx11+?

Yes we could do this. Thanks for uploading the dependencies Joel.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.