Closed Bug 1748983 Opened 5 months ago Closed 5 months ago

Firefox MSIX cannot open certain links

Categories

(Firefox :: Installer, defect, P3)

Firefox 95
defect

Tracking

()

RESOLVED DUPLICATE of bug 1733284

People

(Reporter: polim27, Unassigned)

References

Details

Attachments

(2 files)

Attached video Bugzilla 2022-01-07.mp4

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:95.0) Gecko/20100101 Firefox/95.0

Steps to reproduce:

Since I have installed Firefox MSIX instead of the common installer I experience this strange behaviour:

  1. I open an app on Windows 10 (MS PowerToys in the attached video);
  2. I click on a hyperlink related to an internet webpage

Actual results:

Instead of Firefox opening the webpage as usual, a message appears from Windows saying that "It's impossible to access the specified device, path or file. Probably you don't have the needed authorization"

Expected results:

The hyperlink should have opened in Firefox as it did in the past.

This behavior is common to all the Windows app which have "internal" hyperlinks pointing to webpages (CCleaner is another example).
Have I missed some configuration parameters or is it related to the fact that now Firefox is saved as a WindowsApps in C:\ProgramFiles\WindowsApps... ?
Many thanks in advance

The Bugbug bot thinks this bug should belong to the 'Firefox::Installer' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Installer

Hey polim27,
Can you test on a fresh new profile? You can find more about creating a new profile here : https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems#w_6-create-a-new-firefox-profile .
If possible, you can test this issue on the nightly build as well. Download the build from : https://www.mozilla.org/en-US/firefox/nightly/all/ .

Flags: needinfo?(polim27)

We witnessed this in early testing but we're not quite sure what the cause is and how to address it. It's quite likely that we need to do https://bugzilla.mozilla.org/show_bug.cgi?id=1745437, but I can't mark this a duplicate of that ticket quite yet, since we don't yet know. For internal folks, there's a confidential ticket with the same issue with another program: https://bugzilla.mozilla.org/show_bug.cgi?id=1731261. There's nothing relevant to this ticket in that discussion, which is with a partner, but it's worth connecting some breadcrumbs here.

P3/S3 since we want to improve this, but it's probably raising the priority of Bug 1745437 more.

Severity: -- → S3
Priority: -- → P3
See Also: → 1745437

(In reply to Andrei Purice from comment #2)

Hey polim27,
Can you test on a fresh new profile? You can find more about creating a new profile here : https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems#w_6-create-a-new-firefox-profile .
If possible, you can test this issue on the nightly build as well. Download the build from : https://www.mozilla.org/en-US/firefox/nightly/all/ .

Dear Andrei
As you suggested I opened the profile page via about:profile and, as you can see from the attached picture, I found 4 (!) "default" profile: obviously I've never created anyone of them, it seems that the various Firefox installers from previous releases created them on their own in the past.
Please let me know what you want me to do: delete some profiles and/or create a new profile.
I'll wait for your instructions before doing anything.

Flags: needinfo?(polim27)

(In reply to Nick Alexander :nalexander [he/him] from comment #3)

We witnessed this in early testing but we're not quite sure what the cause is and how to address it. It's quite likely that we need to do https://bugzilla.mozilla.org/show_bug.cgi?id=1745437, but I can't mark this a duplicate of that ticket quite yet, since we don't yet know. For internal folks, there's a confidential ticket with the same issue with another program: https://bugzilla.mozilla.org/show_bug.cgi?id=1731261. There's nothing relevant to this ticket in that discussion, which is with a partner, but it's worth connecting some breadcrumbs here.

P3/S3 since we want to improve this, but it's probably raising the priority of Bug 1745437 more.

Dear Nick
For your information, trying to manage my profiles as suggested by Andrei Purice, after one try online with the results cited before, I tried also offline via Win+r and typing firefox.exe +P in the Run dialog box. As a result I experienced the same bug 1745437 with the error message from Windows saying it could not find firefox.exe. So in my humble opinion (I'm not a developer, only a firefox user) the two bugs are very likely to be related to the same installer issue.

For all
After updating Firefox to release 96 from Microsoft Store, the bug I reported has disappeared: now I can open "internal" hyperlinks from desktop apps as usual in the past.
Firefox online profile manager still gives yesterday's 4 "default" profiles so it seems that the new update didn't add any new profile.
However I still experience bug 1745437 also after the update to rel. 96: I tried to enter the offline profile manager via firefox.exe -P and Windows gave me the same message saying it could not find firefox.exe

PowerToys is running as an administrator in the video in comment #0. CCleaner is also running as an administrator.

Status: UNCONFIRMED → RESOLVED
Closed: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1733284
You need to log in before you can comment on or make changes to this bug.