Closed Bug 1748998 Opened 2 years ago Closed 2 years ago

Address autofill does not work on Joom.com

Categories

(Toolkit :: Form Autofill, defect)

Desktop
All
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox95 --- affected
firefox96 --- affected
firefox97 --- affected

People

(Reporter: atrif, Assigned: tgiles)

References

(Blocks 1 open bug, )

Details

Attachments

(2 files)

Attached image autofill_joom2.gif

Affected versions

  • 97.0a1 (20220105093353)
  • 96.0
  • 95.0.2

Affected platforms

  • Windows 10x64
  • macOS 10.15
  • Ubuntu 20.04

Preconditions

  • browser.search.region: US / extensions.formautofill.available: on
  • credit card details saved

Steps to reproduce

  1. Open Firefox and https://www.joom.com.
  2. Add a product to the cart and try to autofill the address.

Expected result

  • The address is auto-filled.

Actual result

  • Address cannot be auto-filled.

Regression range

  • I will search for one ASAP if there is one.
  • Card details are successfully auto-filled.
Has Regression Range: --- → no
Has STR: --- → yes
OS: Windows → All
QA Whiteboard: [qa-regression-triage]

This is not a recent regression but most likely an implementation bug since I can reproduce it in Fx81 as well.

Assignee: nobody → tgiles

The reason address autofill doesn't work here is due to the form having its autocomplete attribute set to "off". If I change the value to "on", it works as expected. I'm not sure why Joom has the form, as well as the form input elements, autocomplete set to "off".

I guess we could potentially ignore it like with credit cards, but this doesn't feel entirely correct.

Closing as wontfix, as currently it follows the expectations.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.