Newsgroups UI needs folder/subfolder hierarchy

RESOLVED DUPLICATE of bug 38931

Status

--
enhancement
RESOLVED DUPLICATE of bug 38931
16 years ago
12 years ago

People

(Reporter: tin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
The UI for news reading in Moz is terrible.  It will not scale when someone (me)
subscribes to a lot of newsgroups.  I subscribe to several hundred groups and
monitor them.

The UI flatten the Usenet hierarchy in the left pane display.  It should
maintain them as sub-folders, the way that Outlook Express does (and actually
the same ways that text client on *nix does, such as trn/rn/slrn, etc.).

By keeping the display as collapsible groups, it's easier to find and search for
the groups.
reassign to sspitzer.
Assignee: ducarroz → sspitzer
Component: Composition → Mail Window Front End

Comment 2

15 years ago
Might as well triage this:

Severity -> enhancement
Status -> new
Hardware/OS -> All/All
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All

Comment 3

15 years ago
clarify summary:

was: news client UI will not scale with lots of news groups
new: Newsgroups UI needs folder/subfolder hierarchy
Summary: news client UI will not scale with lots of news groups → Newsgroups UI needs folder/subfolder hierarchy

Comment 4

15 years ago
I'm interested in taking a look at what might be required to implement something
close to this functionality.  I've taken a look at the news folder code:

http://lxr.mozilla.org/mozilla/source/mailnews/news/src/nsNewsFolder.cpp

and it looks like it might not be a difficult task to allow the user to organize
groups using local folders, not unlike the local folders themselves.  The code
for maintaining the groups in local folders can probably be borrowed from:

http://lxr.mozilla.org/mozilla/source/mailnews/local/src/nsLocalMailFolder.cpp

If anyone is interested in refactoring the folder-handling code into one of the
common base-classes, that would certainly be handy.

As a curiousity, is this related to the "newsgroup category" functionality
mentioned in nsNewsFolder?
Product: Browser → Seamonkey

Updated

14 years ago
Assignee: sspitzer → mail

Comment 5

12 years ago

*** This bug has been marked as a duplicate of 38931 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.