Slow typing in textarea with specific page background

RESOLVED WORKSFORME

Status

()

P3
enhancement
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: t.tichy, Assigned: john)

Tracking

({perf})

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2b) Gecko/20021016

The smalleet code fragment in which the bug still appears is:
<html><head></head>
<body background="http://www.cdrail.cz/scripts/forum/images/GrayTexture.gif">
<form>
  <textarea  cols="80" rows="12"></textarea>
</form></body></html>

Imteresting is, that the bug depends on the size of textarea. If the number of
rows is greater then 15, the bug doesnt appear.

Reproducible: Always

Steps to Reproduce:
1.create html document with the content like in this bug details
2. open it with mozilla browser (or phoenix 0.3 too)
3. try typing in the textarea 

Actual Results:  
The letter in the textarea appears very slow (about 2 letter per second)

Expected Results:  
show letter inmediately when you type it :-)

Updated

16 years ago
Keywords: perf

Comment 1

16 years ago
On my Win95 machine (686PR200), the usual maximum speed for typing into Mozilla
text areas is about 16 c/s. This maxes out the CPU. On the example here, I get a
maximum of 10 c/s, again maxing out the CPU.

For comparison, NS4.8 on the same code accepts text as fast as I can generate it
(about 40 c/s) while using about 25% of the CPU.

Mozilla appears to be using roughly 16 times the CPU of NS4.8 for typing into a
textarea.

Comment 2

16 years ago
Works for me. Using the code listed in comment 0, and the test URL, the text
area accepts characters as fast as I can type, or hold down a single key.
Severity: normal → enhancement
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Priority: -- → P3
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.