[DOGFOOD]Crash trying to query on bugs on Bugsplat

VERIFIED FIXED in M12

Status

()

P3
blocker
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: scalkins, Assigned: harishd)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+], URL)

(Reporter)

Description

19 years ago
Tested with build 1999102809 M11 Commercial on Win
Steps to reproduce:

1)In Mozilla,go to the URLl: http://scopus/bugsplat/index.cgi.
2) Now click on the link labeled "Build your own Query".
This link is http://scopus/bugsplat/query.cgi

You will crash.

Updated

19 years ago
Assignee: leger → gagan
Severity: major → blocker
Component: Browser-General → Necko
QA Contact: leger → tever
Summary: Crash trying to query on bugs on Bugsplat → [DOGFOOD]Crash trying to query on bugs on Bugsplat
Whiteboard: [PDT+]
Target Milestone: M11

Comment 1

19 years ago
Putting on Dogfood/PDT+ radar.  We need this for daily work in Seamonkey.  Would
be great to fix in M11 too!  :-)

Comment 2

19 years ago
still happens. win32 crashes. linux seems to hang.
trying to get a talkback stack trace on 11/8 builds

Updated

19 years ago
Target Milestone: M11 → M12

Comment 3

19 years ago
m12

Comment 4

19 years ago
the talkback stack trace for this crash looks very odd.
is this the crash others see?

Incident ID 534098
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1627]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]
nsHTMLElement::SectionContains
[d:\builds\seamonkey\mozilla\htmlparser\src\nsElementTable.cpp, line 1631]

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Assignee: gagan → harishd
Status: ASSIGNED → NEW

Comment 5

19 years ago
My crash stack trace is consistent with the one from Talkback. This looks like
the HTML parser problem. Harish...!

#0  0x41254443 in FindTagInSet (aTag=15, aTagSet=0x4125fdc4, aCount=2)
    at nsDTDUtils.h:213
#1  0x4120d5d9 in Contains (aTag=eHTMLTag_body, aTagList=@0x4125fdc0)
    at nsElementTable.cpp:40
#2  0x412100f7 in nsHTMLElement::SectionContains (this=0x82a36f4,
    aChild=eHTMLTag_optgroup, allowDepthSearch=1) at nsElementTable.cpp:1626
#3  0x4121012d in nsHTMLElement::SectionContains (this=0x82a36f4,
    aChild=eHTMLTag_optgroup, allowDepthSearch=1) at nsElementTable.cpp:1629
(Assignee)

Comment 6

19 years ago
Reduced case:

<script></script>
<option>Option 1</option>
(Assignee)

Comment 7

19 years ago
wonder how the <script> got in there!!!

Here is the reduced case:

<option>Option 1</option>
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

19 years ago
Crash was caused due to infinte looping in creating context stack for an
orphaned OPTION.  The crash is fixed......and I'm ready for that...CAR WASH :)

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 9

19 years ago
Verified working on build 1999112908.

Comment 10

19 years ago
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.
You need to log in before you can comment on or make changes to this bug.