Rewrap deletes signature

VERIFIED FIXED in mozilla1.2final

Status

MailNews Core
Composition
VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: Karsten Düsterloh, Assigned: Akkana Peck)

Tracking

Trunk
mozilla1.2final

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Mozilla 1.2b [
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016], mail
composition is in text mode, graphical quote bar is turned off.


Rewrapping mails with quoted text deletes the signature:

Steps to reproduce:
(a) - compose new mail or posting
    - start line with >
    - rewrap
    => signature deleted
(b) - reply to mail or posting
    - rewrap
    => signature deleted

BTW: the graphical quote bar is also visible even though disabled :(

Comment 1

16 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021002

I can see it with Linux. No 1.2b available for testing because bug 1.2b was
treated as WONTFIX, which is also the reason for you last remark.

Akkana, I guess the idea is that when rewrapping you do not want to destroy the
signature and hence remove it. We just need to include it again after rewrapping.

Maybe the better way would be to include the signature upon sending, not when
composing as now.

pi
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All
(Assignee)

Comment 2

16 years ago
Aha: in some cases it was throwing away the final chunk.  Also, I noticed that
the rewrap wasn't undoable as a single chunk, so I fixed that too.  Simple fix,
which I I can get approval to get in for 1.2final.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.2final
(Assignee)

Comment 3

16 years ago
Created attachment 103210 [details] [diff] [review]
Fix: don't end the loop prematurely

Here's the fix.  Seeking review.

Comment 4

16 years ago
Comment on attachment 103210 [details] [diff] [review]
Fix: don't end the loop prematurely

sr=kin@netscape.com
Attachment #103210 - Flags: superreview+

Comment 5

16 years ago
Comment on attachment 103210 [details] [diff] [review]
Fix: don't end the loop prematurely

r=brade
Attachment #103210 - Flags: review+
(Assignee)

Comment 6

16 years ago
*** Bug 174721 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

16 years ago
No longer blocks: 174601
(Assignee)

Comment 7

16 years ago
*** Bug 174601 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
Comment on attachment 103210 [details] [diff] [review]
Fix: don't end the loop prematurely

a=asa for checkin to 1.2 (on behalf of drivers).
Attachment #103210 - Flags: approval+

Comment 9

16 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/2002101815 (+ patches
101274, 101762, 103210)

Patch WFM, but it adds a newline to the signature if it does not end in one.

pi
(Assignee)

Comment 10

16 years ago
Fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
*** Bug 175805 has been marked as a duplicate of this bug. ***

Comment 12

16 years ago
*** Bug 177170 has been marked as a duplicate of this bug. ***

Comment 13

16 years ago
Verified when verifying bug 173953, this was mentioned in that bug.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.