1.2b sucks and won't get localization - missing .dtd updates for locale version number

RESOLVED FIXED in mozilla1.2beta

Status

()

Core
Localization
P1
blocker
RESOLVED FIXED
16 years ago
7 years ago

People

(Reporter: Robert Kaiser, Assigned: Robert Kaiser)

Tracking

({l12y})

Trunk
mozilla1.2beta
x86
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

16 years ago
As
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/xpfe/global/resources/locale/en-US/brand.dtd&rev=&root=/cvsroot
states, the version number in brand.dtd wasn't updated last night for 1.2b, the
same is true for region.dtd and I guess that for some component even the
localeVersion string in chrome.rdf wasn't updated correctly.

If version strings changes are performed that incomplete and there's no time to
check for it because they're flipped only very very very short times before the
release, we won't ever be able to ship langauge packs again and we could drop
locale support completely.

I'll search for other version numbers that might be wrong as soon as I've pulled
and build my tree.
(Assignee)

Comment 1

16 years ago
BTW, this is the same thing that bug 168923 was about, and it makes bug 168066 a
WONTFIX in my eyes :((
(Assignee)

Comment 2

16 years ago
reassigning to self, making blocker as it is a blocker for L10n people.

If bug 169074 would be solved, we could avoid such problems completely.
Assignee: rchen → kairo
Severity: normal → blocker
Priority: -- → P1
Target Milestone: --- → mozilla1.2beta
(Assignee)

Comment 3

16 years ago
Created attachment 103182 [details] [diff] [review]
patch updating all known non-fitting locale version strings

OK, this patch fixes all problem I could find.

First, there are those two .dtd files, which still have 1.2a
Then, inspector never gets updated to newer localeVersions (well, it was once
on a branch - IIRC that was 1.1) and still has 0.9.4
Then, there is a built but empty mac donloadmanager directory which still has
1.0.0
And, CaScadeS looks a bit messed up with localeVersion strings entirely (having
the string in locale/ but missing it in content/) and has 0.1.7 which looks
imported from the previous mozdev project

For L10n people, it's important that all components share the same version
string, or it will get much harder to even provide correct and working L10n for
those components.

Updated

16 years ago
Blocks: 174647
Comment on attachment 103182 [details] [diff] [review]
patch updating all known non-fitting locale version strings

r=jbetak
Attachment #103182 - Flags: review+
leaf, tao:

we really need to get the release scripts fixed. We miss brand.dtd and
region.dtd in *every* release. You might have seen an email about it two weeks ago.

I caught the four contents.rdf files while working on bug 137331 and wanted to
file a follow-up bug after wrapping up bug 137331. Kudos to kairo for catching this!
Status: NEW → ASSIGNED
leaf, are we using flipLocale.sh and strsubs.pl (see bug 154927)? If so, could
we make them part of the Mozilla tree? :-)
(Assignee)

Comment 8

16 years ago
asked bz for sr= (he sr'ed bug 168923 as well).

Asa, can you a= this change? (If we get sr before, I'll mail you anyway...)

Updated

16 years ago
Keywords: l12y
QA Contact: ruixu → kasumi
Comment on attachment 103182 [details] [diff] [review]
patch updating all known non-fitting locale version strings

sr=bzbarsky
Attachment #103182 - Flags: superreview+
*** Bug 175396 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Blocks: 161762

Updated

16 years ago
Keywords: mozilla1.2

Comment 11

16 years ago
Comment on attachment 103182 [details] [diff] [review]
patch updating all known non-fitting locale version strings

a=asa for checkin to 1.2 (on behalf of drivers).
Attachment #103182 - Flags: approval+

Updated

16 years ago
QA Contact: kasumi → blee
(Assignee)

Comment 12

16 years ago
Checking in xpfe/global/resources/locale/en-US/brand.dtd;
/cvsroot/mozilla/xpfe/global/resources/locale/en-US/brand.dtd,v  <--  brand.dtd
new revision: 1.10; previous revision: 1.9
done
Checking in xpfe/global/resources/locale/en-US/region.dtd;
/cvsroot/mozilla/xpfe/global/resources/locale/en-US/region.dtd,v  <--  region.dtd
new revision: 1.13; previous revision: 1.12
done
Checking in extensions/inspector/resources/content/contents.rdf;
/cvsroot/mozilla/extensions/inspector/resources/content/contents.rdf,v  <-- 
contents.rdf
new revision: 1.6; previous revision: 1.5
done
Checking in extensions/inspector/resources/locale/en-US/contents.rdf;
/cvsroot/mozilla/extensions/inspector/resources/locale/en-US/contents.rdf,v  <--
 contents.rdf
new revision: 1.3; previous revision: 1.2
done
Checking in xpfe/components/download-manager/resources/mac/contents.rdf;
/cvsroot/mozilla/xpfe/components/download-manager/resources/mac/contents.rdf,v 
<--  contents.rdf
new revision: 1.3; previous revision: 1.2
done
Checking in extensions/editor/cascades/resources/locale/en-US/contents.rdf;
/cvsroot/mozilla/extensions/editor/cascades/resources/locale/en-US/contents.rdf,v
 <--  contents.rdf
new revision: 1.2; previous revision: 1.1
done

Hopefully FIXED.

Perhaps I'll file a bug with a patch to get _really all_ locale version strings
updated for 1.2final correctly. I'm not sure we should trust leaf's script again...
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.