Closed Bug 1749909 Opened 4 months ago Closed 4 months ago

mail notification link does not work

Categories

(Thunderbird :: Mail Window Front End, defect)

Thunderbird 97
x86_64
All
defect

Tracking

(thunderbird_esr91 unaffected, thunderbird97 fixed)

RESOLVED FIXED
98 Branch
Tracking Status
thunderbird_esr91 --- unaffected
thunderbird97 --- fixed

People

(Reporter: tobias.thommes, Assigned: rnons)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:95.0) Gecko/20100101 Firefox/95.0

Steps to reproduce:

When receiving an email, a notification rectangle is displayed on the main-screen.
Usually this rectangle contains a link that jumps to the Thunderbird main-window to display the newly arrived email.

Actual results:

The link does not work. Thunderbird is not put into forground and the email is not opened.

OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64

I've noticed this too.

Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 10 → All

However, when selecting the use of system-notifications in the settings, the link works fine...

Attached image working_setting.jpg

with this setting, the notification link works

Just saw this bug, I sent a fix to bug 1748355.

Regressed by: 1748355
Assignee: nobody → remotenonsense
Status: NEW → ASSIGNED
Target Milestone: --- → 98 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/a57046445d9d
Fix MailUtils undefined error in foldersummary.js. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED

The problem still persists in the new Version 97.0b2 ... not sure if the fix is just not "upstream" yet or if the fix did not work

See the flags, status-thunderbird97:affected (this will say fixed once it lands on beta)

Comment on attachment 9259058 [details]
Bug 1749909 - Fix MailUtils undefined error in foldersummary.js. r=mkmelin

[Approval Request Comment]
Regression caused by (bug #): bug 1748355
User impact if declined: Click mail notification does not open the mail
Testing completed (on c-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): low

Attachment #9259058 - Flags: approval-comm-beta?

Comment on attachment 9259058 [details]
Bug 1749909 - Fix MailUtils undefined error in foldersummary.js. r=mkmelin

[Triage Comment]
Approved for 97.0b3.

Attachment #9259058 - Flags: approval-comm-beta? → approval-comm-beta+

thanks. The fix now works for me in the Beta3 :-)

You need to log in before you can comment on or make changes to this bug.