weird default UI font with xft

RESOLVED WORKSFORME

Status

()

Core
XUL
RESOLVED WORKSFORME
16 years ago
6 years ago

People

(Reporter: blizzard, Assigned: blizzard)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

16 years ago
The default UI font seems to get mapped to the serif font.  It should end up
being mapped to the sans font.
(Assignee)

Updated

16 years ago
Blocks: 172768

Comment 1

16 years ago
the ui font is mapped to whatever is the default font for web pages. it should
be trivial to query the OS to determine what the proper application font should be.
The tricky part is determining whether we're using Xft from the relevant code.

Comment 3

16 years ago
it isn't in a property file somewhere (knows nothing about XFT).

is this the right component?
With Xft, the default UI font is mapped to the name "sans-serif".  Without Xft,
such a font may not exist, and is likely to be wrong.

(That said, I'm actually seeing a reasonable font as my default, but that's
because the GTK1 widget default font isn't that unreasonable with Xft+GTK2. 
That may not be true for everyone.)
(That said, this may really be a GTK2-specific bug rather than an Xft-specific
bug.  But in either case it's correctly assigned.)

Comment 6

16 years ago
for me, it's weird. the ui font is whatever is set as your default proportional
font under preferences-->appearance-->fonts. so if it's set to 'sans serif' and
your sans serif font is 'lucida bright', that's what you get for your ui.

Comment 7

16 years ago
Is there a workaround? Editing crome files or something?
(Assignee)

Comment 8

16 years ago
See bug #176842.

Comment 9

16 years ago
I applied the patch from 176842, and I still get the serif font as my default ui
font.  Instead, what should happen is that the ui font should match the GTK ui
font, not the font specified in the fonts dialog as the default font for viewing
web pages.  

Note that the first time the browser starts up, it has an acceptable ui font,
but after changing the font prefs to my liking, and restarting the browser, the
ui font changes too.

Here's a workaround that works for me:

Set your font prefs how you like them, and close the browser.  Then edit
~/.mozilla/<username>/<xxx>.slt/prefs.js so that the line specifying the default
serif font is commented out:

//user_pref("font.name.serif.x-western", "Times New Roman");

It seems that by default, when this line is not present, mozilla will take the
default serif font in /etc/fonts/fonts.conf as its own default serif font.

I want my default serif font to be Times New Roman, so in my fonts.conf, I have
a section that starts:

<!--
  Provide required aliases for standard names
-->
        <alias>
                <family>serif</family>
                <prefer>
                        <family>Times New Roman</family>

make similar adjustments according to your preference.

Once the serif pref is commented out in prefs.js as described above, the ui font
seems to be the one specified in fonts.conf as an alias for helvetica (maybe
because In my setup (RH8), the GTK1 default font is helvetica).  

I want my ui font to be Tahoma, so I have a section like this:

	<alias>
		<family>Helvetica</family>
		<accept><family>Tahoma</family></accept>
	</alias>

make a similar entry in your fonts.conf.

Then, restart the browser, and hopefully, all your fonts will be as you wish
them to be.

Comment 10

16 years ago
Another way to set the UI font without messing with Preferences is to put
something like this in your chrome/userChrome.css file:

* {
        font-family: Arial !important;
        font-size: 12pt !important;
}
* might be a little too much.
I used to have this : 
textbox, description, label, tree, button, toolbarbutton, #ButtonEval, tab,
statusbar, window, menubar, menubutton, menulist, menu, menuitem,
.bookmark-item, toolbarbutton.bookmark-item
{
        font-size: 11px !important;
        font-family: verdana !important;
}
 :))))
*** Bug 183417 has been marked as a duplicate of this bug. ***

Comment 13

15 years ago
For me (RedHat 8.0) the following helped:

- install gtk-engines rpm (this made the font larger)
- Edit -> Preferences -> Appearance -> Fonts -> Proportional set to Sans Serif

but I can't say that that was obvious...

now it looks cool though !
(Assignee)

Comment 14

15 years ago
*** Bug 175705 has been marked as a duplicate of this bug. ***

Comment 15

15 years ago
*** Bug 189729 has been marked as a duplicate of this bug. ***

Comment 16

15 years ago
Does the GUI font need to be mapped to the Serif or Sans Serif setting? Would 
it be a bad idea to have an additional "GUI Font" setting, independent of the 
rendering fonts settings?
(Assignee)

Comment 17

15 years ago
I've actually done this with the Red Hat packages so you can set the UI font. 
Right now there's a pref that sets it to "Sans 10".

Comment 18

15 years ago
Nice! I assume it will be merged upstream?

(Assignee)

Comment 19

15 years ago
I'm not sure.  The patch is pretty hacky and is also kind of Red Hat specific.

Comment 20

15 years ago
I'm testing mozilla-1.2.1-20 in Red Hat Phoebe right now and I can't seem to 
find the option to change the UI font. Am I missing something obvious?

Comment 21

15 years ago
mattias: edit /usr/lib/mozilla-1.2.1/defaults/pref/xft.js (global change) or
~/.mozilla/<profile>/<random>/prefs.js (per user). however, the per-user file
seems to be overwritten (and the preferences removed) whenever i exit mozilla so
it isn't very useful for me.


(Assignee)

Comment 22

15 years ago
Don't edit it while mozilla is running. :)

Comment 23

15 years ago
i don't edit it while running. the first time i run it, it works. but when it
exits, it overwrites the preferences again.
(Assignee)

Comment 24

15 years ago
*** Bug 197038 has been marked as a duplicate of this bug. ***

Comment 25

15 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

I have similar problem on linux rh73 with mozilla 1.3.
After installation of mozilla there was by default "Serif" font in menus (Times
in my case). I was confused because this font is not suitable for
menus(IMHO).
I was wandering what happens. I found that switching font "Proportional"
in Preference/Appearance/Fonts influences font used in whole mozilla environment
(menus etc.). I do not think this is correct. This setting should influence only
pages rendering.

Comment 26

14 years ago
*** Bug 198763 has been marked as a duplicate of this bug. ***

Comment 27

11 years ago
This has long been fixed in the newer versions of mozilla. recommend closing.
With this distro build of Firefox 8, poking the "default" Gnome3 font in the system settings changes the font being used for chrome (e.g. tab titles) but not any web page font.  I believe this is the correct behavior
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.