Closed Bug 1750296 Opened 4 months ago Closed 4 months ago

Perma /cookies/schemeful-same-site/schemeful-navigation.tentative.html | Navigate cross-scheme - assert_not_equals: SameSite=strict cookies cannot be sent to cross-scheme navigations got disallowed value "0.4338496722955565"

Categories

(Core :: Networking: Cookies, defect, P1)

defect

Tracking

()

RESOLVED FIXED
96 Branch
Tracking Status
firefox-esr91 --- unaffected
firefox96 --- fixed
firefox97 --- unaffected
firefox98 --- unaffected

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Regression)

Details

(Keywords: intermittent-failure, regression)

Filed by: nbeleuzu [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer?job_id=364183208&repo=mozilla-release
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/GNxCvWsKQaeFbgXfWkttzg/runs/0/artifacts/public/logs/live_backing.log


[task 2022-01-14T21:47:04.669Z] 21:47:04     INFO - TEST-START | /cookies/attributes/attributes-ctl.sub.html
[task 2022-01-14T21:47:04.724Z] 21:47:04     INFO - PID 1299 | 1642196824722	Marionette	WARN	Ignoring event 'DOMContentLoaded' because document has an invalid readyState of 'complete'.
[task 2022-01-14T21:47:04.780Z] 21:47:04     INFO - Deleting all cookies
[task 2022-01-14T21:47:04.789Z] 21:47:04     INFO - Deleting all cookies
[task 2022-01-14T21:47:04.796Z] 21:47:04     INFO - Deleting all cookies
[task 2022-01-14T21:47:04.805Z] 21:47:04     INFO - Deleting all cookies
[task 2022-01-14T21:47:04.806Z] 21:47:04     INFO - PID 1299 | 1642196824805	Marionette	WARN	Ignoring event 'DOMContentLoaded' because document has an invalid readyState of 'complete'.
[task 2022-01-14T21:47:04.812Z] 21:47:04     INFO - Deleting all cookies
[task 2022-01-14T21:47:04.821Z] 21:47:04     INFO - Deleting all cookies
[task 2022-01-14T21:47:04.828Z] 21:47:04     INFO - Deleting all cookies
[task 2022-01-14T21:47:04.837Z] 21:47:04     INFO - 
[task 2022-01-14T21:47:04.838Z] 21:47:04     INFO - TEST-PASS | /cookies/schemeful-same-site/schemeful-navigation.tentative.html | Navigate same-scheme 
[task 2022-01-14T21:47:04.838Z] 21:47:04     INFO - TEST-UNEXPECTED-FAIL | /cookies/schemeful-same-site/schemeful-navigation.tentative.html | Navigate cross-scheme - assert_not_equals: SameSite=strict cookies cannot be sent to cross-scheme navigations got disallowed value "0.4338496722955565"
[task 2022-01-14T21:47:04.838Z] 21:47:04     INFO - schemeful_navigation_test/</</window.onmessage<@http://web-platform.test:8000/cookies/schemeful-same-site/schemeful-navigation.tentative.html:27:34
[task 2022-01-14T21:47:04.838Z] 21:47:04     INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:2534:25
[task 2022-01-14T21:47:04.838Z] 21:47:04     INFO - Test.prototype.step_func/<@http://web-platform.test:8000/resources/testharness.js:2581:35
[task 2022-01-14T21:47:04.839Z] 21:47:04     INFO - TEST-OK | /cookies/schemeful-same-site/schemeful-navigation.tentative.html | took 232ms

Set release status flags based on info from the regressing bug 1750264

adjust web-platform test expectations for network.cookie.sameSite.schemeful being set to false. a=Aryx
https://hg.mozilla.org/releases/mozilla-release/rev/648a65df3c3f

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 96 Branch

Changing the priority to p1 as the bug is tracked by a release manager for the current beta.
See What Do You Triage for more information

Priority: P5 → P1
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.