Plugin / software installation behavior issue

RESOLVED DUPLICATE of bug 83754

Status

()

P3
normal
RESOLVED DUPLICATE of bug 83754
16 years ago
16 years ago

People

(Reporter: kelv, Assigned: peterl-bugs)

Tracking

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
If you go to a website that uses a plugin (e.g. in this case Java) and Mozilla
detects that it is not installed, the user is alerted and given the option to
download the plugin for their platform.

However, if the user goes to another site (or the same site) while downloading
the Java plugin, they are prompted about downloading again, even if the plugin
is already in the process of downloading. It seems a bit pointless to display
the dialogue box again with its current message.

Perhaps instead a warning (with 'disable notice in future' checkbox) shoud be
displayed that reads 'The plugin required to display this page properly is
currently downloading. For now page components using it will not be displayed'
or something similar.

URL supplied is just one with the Java plugin.

Comment 1

16 years ago
It may be extremely difficult to be able to denote that the user has selected to
actually download the plug-in since the user action is outside of the window
frame in which the default plug-in is being displayed. We cannot, for certain,
know the action that the user has chosen in the other window, or that they chose
to download the necessary plug-in

Comment 2

16 years ago
reassign
Assignee: beppe → peterl

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 83754 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Priority: -- → P3
Resolution: --- → DUPLICATE
Target Milestone: --- → Future
You need to log in before you can comment on or make changes to this bug.