Closed Bug 175075 Opened 17 years ago Closed 17 years ago

Many table styles not functioning as expected

Categories

(Core :: Layout: Tables, defect)

PowerPC
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 4510

People

(Reporter: shawn, Assigned: karnaze)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021016 Chimera/0.5+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021016 Chimera/0.5+

http://alterior.net/col_style.html tests some CSS applied to various table
elements. Though properties like border appear to work, styles related to color
(color, background-color) and text formatting (white-space, font-weight,
font-style, etc.) do not. Additionally (though this could be due to my
misinterpretation of the collapsing border model), the border applied to
tr.active disappears on the row's sides.

Reproducible: Always

Steps to Reproduce:
1. load up the test case
2. look at it



Expected Results:  
As far as I know, <col> should be just a styleable as the other table elements.
The left column (col.name) should be italicized, and when the table is
constrained, the white-space: nowrap property should prevent the column from
collapsing (words on separate lines).

The center column (col.description, only within the <tdody>) is rendered as
expected, with top and bottom borders collapsed to the enclosing table's.

The right column (col.sort) should be bold, and aligned center, with a slightly
darker background than the rest of the table (except where tr.active overrides
it). The left and right borders of the active row (tr.active) should collapse to
those of the enclosing table (instead of disappearing completely).
Summary: Man table styles not functioning as expected → Many table styles not functioning as expected
> As far as I know, <col> should be just a styleable as the other table elements.

Nope.  See http://www.w3.org/TR/CSS21/tables.html#q4 -- the only properties you
can set on <col> are 'border', 'background', 'width', 'visibility'.

The brokenness of background is bug 4510

*** This bug has been marked as a duplicate of 4510 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.