If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[PP] clicking on 'mozilla' dropdown within taskswitcher toolbar causes a crash

VERIFIED DUPLICATE of bug 15946

Status

()

Core
XUL
P3
major
VERIFIED DUPLICATE of bug 15946
18 years ago
18 years ago

People

(Reporter: Claudius Gayle, Assigned: saari (gone))

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Overview Description: clicking on the mozilla dropdown in the taskswitcher toolbar
(bottommost toolbar) causes apprunner to crash.

Steps to Reproduce:
1) Launch apprunner
2) Click once or sometiems several times on 'Mozilla'
3) Crash.

Actual Results:
My linux box gives a Gtk-WARNING **: invalid cast from (NULL) pointer to
'GtkWidget' just before dying.

Expected Results:
Don't know the spec on this but at the very least a XUL popup with maybe
some relevant mozilla links. Definitely not hte crash though.

Build Date & Platform Bug Found:
This bug was found and reproduced on Linux RH6. It was also tested and
reproduced on WinNT sp4. (1999102809 build)

Additional Builds and Platforms Tested On:
This bug was tested and DID NOT reproduce on MacOS 8.5.1(1999102811)

Additional Information:
the bug is highly reproducable but I have not been able to generate a
stack trace yet due to other diffuculties (talkback, gdb)

Updated

18 years ago
Assignee: trudelle → saari
Target Milestone: M12

Comment 1

18 years ago
Probably a dup of the one I reported recently, but without involving another
menu already open. Were you really ever able to crash with one click?
reassigning to saari.
(Reporter)

Comment 2

18 years ago
on windows and linux a mouseover yeilds:
JavaScript Error: TypeError: tipElement has no properties
URL: file:///D:/the directory seamonkey is in/chrome/navigator/content/
default/tooltip.js

At this point one click on linux will crash you with the above Gtk WARNING
on Windows(NT) it's only reproducing haphazardly.
(Reporter)

Comment 3

18 years ago
*** Bug 15407 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 4

18 years ago
*** This bug has been marked as a duplicate of 15946 ***

Comment 5

18 years ago
verified as a dup
You need to log in before you can comment on or make changes to this bug.