"sometext <br>text" has extra vertical space if text large enough, or container small enough

RESOLVED WORKSFORME

Status

()

P3
trivial
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: bugzilla.20.endlisnis, Assigned: attinasi)

Tracking

Trunk
Future
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016

That page contains a table with "Thursday <br>night" (obviously this text varies
from day to day, but this should still work) in a cell.  When I make the text
large enough so that the word "Thursday" takes up all of the horizontal space
available, there is an extra vertical space introduced between "Thursday" and
"night".

Reproducible: Always

Steps to Reproduce:
1. Load that page
2. Hit Cntl++ a few times, until this is exibited.

Actual Results:  
The "Thursday night" cell was displayed as:
"Thursday

night"

Expected Results:  
It should not have introduced any extra vertical spacing for a line-wrap point
that already contained a <br>.  Should have looked like this:
"Thursday
night"
WFM on OS X (FizzillaCFM 2002101612 and Chimera 0.5).
(Reporter)

Comment 2

16 years ago
Created attachment 103542 [details]
Example of incorrect text wrapping
(Reporter)

Comment 3

16 years ago
I've added an attachment which exhibits the problem more consistently.  The
referenced URL changes from day to day and doesn't always exhibit the bug.

Comment 4

16 years ago
worksforme with linux trunk build 20021020.
(Reporter)

Comment 5

16 years ago
I tried it (my attachment) again with "Mozilla/5.0 (Windows; U; Windows NT 5.0;
en-US; rv:1.2b) Gecko/20021021", and it still doesn't work.  Maybe it's just
something with the windows build?
(Reporter)

Comment 6

16 years ago
Created attachment 103585 [details]
The two tables in this example SHOULD look identical

When I view this attachment using "Mozilla/5.0 (Windows; U; Windows NT 5.0;
en-US; rv:1.2b) Gecko/20021021", and every previous version that I've tried,
then the first table has more vertical space between "Thursday" and "night"
than table2 has.
Attachment #103542 - Attachment is obsolete: true
(Reporter)

Comment 7

16 years ago
Created attachment 103590 [details]
This is what it looks like for me
(Reporter)

Updated

16 years ago
Hardware: All → PC

Updated

16 years ago
QA Contact: petersen → moied

Comment 8

16 years ago
Confirmed bug using branch build 20021021 on winxp SP1
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3

Updated

16 years ago
Target Milestone: --- → Future

Comment 9

14 years ago
Testcase WFM, 1.8a6 Gecko/20041126.
(Reporter)

Comment 10

14 years ago
Just tested in "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0" and I could not proproduce anymore. 
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.