Arabic letters not attached to another letter are displayed much smaller than the rest of the word

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
15 years ago
11 years ago

People

(Reporter: Amine Noueiry, Unassigned)

Tracking

({intl})

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
In all arabic web pages I went to (www.gn4msnbc.com), some letters in a word are
displayed much smaller than the rest of the word. More specifically, every
letter not attached to another letteris displayed much smaller than the rest of
the word. In appearance preferences, drop down menus when arabic or hebrew
languages are selected, are greyed out and don't work.

Comment 1

15 years ago
Renders relatively fine in 2002101612, although some glyphs seem thinner than
others. In that case, it is because Mozilla refueses to implement ATSUI
rendering (which would render _anything_ just fine; see the simple text editor
TextEdit and its professional rendering).

Can confirm that Mozilla reports that no fonts are available for Arabic...
although in /Library/Fonts/ we have AlBayan, Baghdad, Geeza, KufiStandard and
Nadeem. We also have Arial Unicode MS, Code 2000, Bitstream Cyberbit and a few
other multiple-block Unicode fonts that could be used to render Arabic.
Summary: Bad Arabic display, can't pick arabic/hebrew font → Bad Arabic display, can't pick arabic/hebrew font
ftang, can you take a look at this?
Assignee: mkaply → ftang

Comment 3

15 years ago
Amine, please report the problem with the font menu as a separate bug. Revising
summary to address the first reported issue.

What build ID are you reporting this bug against?

Severity: major → normal
Component: BiDi Hebrew & Arabic → Layout
Keywords: intl
Summary: Bad Arabic display, can't pick arabic/hebrew font → Arabic letters not attached to another letter are displayed much smaller than the rest of the word
There's probably no need for a separate bug for the font selection issue: it
sounds like a duplicate of bug 110655.
(Reporter)

Comment 5

15 years ago
I'm using build 2002101612. 

Comment 6

15 years ago
WorksForMe using FizzillaCFM/2002101808 on 10.1.5. Amine, please attach a
screenshot.

Comment 7

15 years ago
mark it as assign
We do use ATSUI for Arabic. We DONT use QD for Arabic.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 8

13 years ago
what a hack. I have not touch mozilla code for 2 years. I didn't read these bugs
for 2 years. And they are still there. Just close them as won't fix to clean up.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX

Comment 9

13 years ago
Mass Bug Re-Open of bugs Frank Tang Closed with no good reason. Spam is his
fault not my own
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 10

13 years ago
Mass Re-assinging Frank Tangs old bugs that he closed won't fix and had to be
re-open. Spam is his fault not my own
Assignee: ftang → nobody
Status: REOPENED → NEW
I remember seeing this problem in Safari several years ago, however I haven't seen it neither in Safari nor in Firefox/Mozilla for a long time. Therefore I assume it was an OS (or font) problem, which was corrected in some release of OS X.
Also, the site in the URL field is dead.

Marking WFM. Please re-open if you can reproduce.
Status: NEW → RESOLVED
Last Resolved: 13 years ago11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.