nullplugin should remember if user has clicked cancel for the same mimetype earlier

RESOLVED DUPLICATE of bug 83754

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 83754
16 years ago
5 years ago

People

(Reporter: Rune Frøysa, Assigned: rubydoo123)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826

If the user earlier in the same browser-session has clicked cancel in a "click
here to download plugin" dialog, Mozilla should not pop-up a new request for the
same mimetype, atleast not within the same browser session.

I guess this can be implemented by making
modules/plugin/samples/default/unix/nullplugin.c contain a hash of all mimetypes
that it has displayed dialogs for, and check for this early in makeWidget()

Reproducible: Always

Steps to Reproduce:
1.Enter any page that contains a ref. to a mimetype that requires a plugin that
is not installed
2.click cancel on the download dialog
3.re-enter the page

Actual Results:  
The dialog reappares

Expected Results:  
It should have remembered that I didn't want the plugin.

*** This bug has been marked as a duplicate of 83754 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
*** Bug 258654 has been marked as a duplicate of this bug. ***

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.