Clicking with middle mouse button on bookmark in bookmark sidebar doesn't work as expected.

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: mehturt, Assigned: p_ch)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021017 Phoenix/0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021017 Phoenix/0.3

Opening a file:// bookmark in a new tab by clicking with a middle button on it
opens also other file:// bookmarks in existing tabs.

Reproducible: Always

Steps to Reproduce:
1.Make a few (3 in my case) bookmarks pointing to a file on your file system
(file:// bookmarks)
2.Click on the first bookmark with a middle mouse button.


Actual Results:  
All 3 file:// bookmarks are opened. If you already had multiple tabs opened, the
conten of these tabs is replaced with the one of bookmarks.

Expected Results:  
Open a new tab with the bookmark that was clicked on.

Comment 1

16 years ago
I don't understand these steps.

"1.Make a few (3 in my case) bookmarks pointing to a file on your file system
(file:// bookmarks)
2.Click on the first bookmark with a middle mouse button."

Make 3 bookmarks pointing to the same file? Click where with the middle mouse
button? Bookmarks manager? Sidebar? Menu? Bookmarks toolbar?

Comment 2

16 years ago
Here's what I did and got on 20021019 Linux:

(1)I typed in a URL of a page on my own system (the mirror of my website at
/var/www/index.html, so file:///var/www/index.html)
(2)I bookmarked that page
(3)I middle-clicked on it in the sidebar

What happened was that every single bookmark not in a folder/group was opened in
a new tab (I had to spend a good amount of time just closing them all down)

(4)After closing all those tabs I exited and restarted Phoenix
(5)Middle clicked on the same bookmark again

This time, as expected, the page opened in a new tab and that was the only page
to open.

Fwiw, the same page when bookmarked instead at http://localhost/ did exactly the
same thing, despite it being http. I can't quite tell for http://127.0.0.1/
because I had tried something else before then. That something else was to
bookmark a page not on my system *after* I had bookmarked the localhost page on
my system but before Middle-clicking on the first (local) bookmark.
Middle-clicking on the bookmark for localhost then opened up a new tab with that
page and none other. I don't know how much to read into this though because I
had been messing around with the same pages so much by then...

Comment 3

16 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021019 Phoenix/0.3

I can't reproduce on Windows XP Pro.

Following the original instructions, I only get the single new tab with the
local file bookmark I clicked.

Comment 4

16 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021019 Phoenix/0.3

Works for me on Linux. What are your tabbed browsing preferences? Have you tried
it with a new profile?

Comment 5

16 years ago
works for me on linux 10/19

Comment 6

16 years ago
This is not an easy bug to recreate, but it can be recreated even with a new
profile.

(1)Browse to a few sites and bookmark them


Now here is the kicker; presumably the last bookmarked url is in the rightmost
tab at this point. If you middle click on its [newly created] bookmark in the
sidebar it will be opened up in a new tab, no problems. So, instead, to recreate
the bug, do the following:

(2)close the tab containing the most recently bookmarked url
(3)middle click on the bookmark in the sidebar

Result: the mouse flickers a bit and tabs are opened up containing every
existing bookmark.

This seems to be happening with all bookmarks, local or not.

But, if you select any bookmark up to the penultimate one (the one second from
the bottom), then this behaviour doesn't occur. It also doesn't occur if you
leave the tab of the last created bookmark open and middle click on its
bookmark. Shutting down and restarting also clears the problem.
(Reporter)

Comment 7

16 years ago
ok.. sorry Asa, I try to describe again..

Steps to Reproduce:
1.Make a few (3 in my case) bookmarks pointing to a file on your file system
(file:// bookmarks) - I have 3 bookmarks pointing to 3 different directories on
my filesystem

2.Click on the first of the 3 bookmarks in your bookmark sidebar with a middle
mouse button.
(Reporter)

Comment 8

16 years ago
I just downloaded latest nightly build and erased my all my prev. files
(including .phoenix directory).

Clicking with a middle mouse button on a bookmark in bookmark folder right after
starting Phoenix opens 2 tabs - one with about:blank and the 2nd one with the
bookmark clicked on.

Comment 9

16 years ago
I can reproduce as per comment #6.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021020 Phoenix/0.3,
build 2002102008





Comment 10

16 years ago
I can now confirm the original bug and it appears to be the same as the related
bug I discovered. Basically, middle-clicking a recently bookmarked URL opens up
every bookmark in a new tab *IF* you first close down the tab of the most
recently bookmarked URL.

Can someone repeat this in Windows and determine if this is cross-platform or
Linux-only?

(1)open a new tab, browse to http://www.slashdot.org/ and bookmark it
(2)open another new tab, browse to http://www.canada.com/ and bookmark it

(3)close tab containing www.canada.com
(4)open the booksmarks sidebar if not open already
(5)middle-click on canada.com bookmark in side bar

Alternatively:
(3)close tab containing www.canada.com
(4)close tab containing www.slashdot.org
(5)middle-click on slashdot.org bookmark in side bar

If you browse to all the sites in the same tab, then closing that tab before
opening *any* of the newly created bookmarks is sufficient to bring about the
bug (this would appear to be what the original reporter did).
(Reporter)

Comment 11

16 years ago
it seems to work correctly with 0.3 on Win2k

Comment 12

16 years ago
Thankyou. Confirming as a Linux-only bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 13

16 years ago
yet another steps to reproduce (tried with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021029 Phoenix/0.4) - brand new install (no previous phoenix, no .phoenix directory or bookmarks or whatever..)

1. start Phoenix
2. open Bookmarks sidebar
3. go to whatever page, www.cnn.com - it doesn't matter - and bookmark it
4. click on 'Phoenix project' bookmark in the sidebar with left mouse button
5. click with middle mouse button on another bookmark in the sidebar (so it opens in a new tab) - I clicked on Phoenix extensions
6. close the Phoenix extensions tab (tab #2)
7. repeat step 5

the cnn.com or whatever page you bookmarked is loaded in tab #1 (or no tab - depends on your settings)
(Reporter)

Updated

16 years ago
Summary: Clicking with middle mouse button on file:// bookmark doesn't work as expected. → Clicking with middle mouse button on bookmark in bookmark sidebar doesn't work as expected.

Comment 14

16 years ago
Michal,

Are you still getting this bug? I'm no longer getting it with 20021102 so I'm
going to mark it WFM. If you are still getting it just reopen it.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 15

16 years ago
yes, the problem seems to be gone now..
using Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021103 Phoenix/0.4
Status: RESOLVED → CLOSED
Resolution CLOSED is deprecated.
Status: CLOSED → REOPENED
Resolution: WORKSFORME → ---
Re-resolving as WFM.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
Mass-verifying of former CLOSED bugs.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.