crash while editing my .Mac (Main Menu) using Apple's Web Page interface

RESOLVED DUPLICATE of bug 167178

Status

Camino Graveyard
General
--
critical
RESOLVED DUPLICATE of bug 167178
15 years ago
15 years ago

People

(Reporter: Glen White, Assigned: saari (gone))

Tracking

({crash})

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021017 Chimera/0.5+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021017 Chimera/0.5+

I believe it has something to do with the scripting Apple uses for re-arranging
items on the main menu of a "HomePage" account. For example, one can move items
around depending on how they want the order of their pages to be displayed to
visitors. Although my second guess (because I don't understand how to read the
crash log info) is Mouse click problems while on that page.

Crash Log:
**********

Date/Time:  2002-10-18 09:25:07 -0400
OS Version: 10.2.1 (Build 6D52)
Host:       VoodooChild

Command:    Navigator
PID:        675

Exception:  EXC_BAD_INSTRUCTION (0x0002)
Code[0]:    0x00000002Code[1]:    0x01f49354

Thread 0 Crashed:
 #0   0x01f49354 in 0x1f49354
 #1   0x050831f4 in
_ZN13nsCOMPtr_base18assign_from_helperERK15nsCOMPtr_helperRK4nsID
 #2   0x0066e8a0 in
_ZN16XPCWrappedNative12GetNewOrUsedER14XPCCallContextP11nsISupportsP21XPCWrappedNativeScopeP18XPCNativeInterfacePPS_
 #3   0x00669e40 in
_ZN10XPCConvert24NativeInterface2JSObjectER14XPCCallContextPP26nsIXPConnectJSObjectHolderP11nsISupportsPK4nsIDP8JSObjectPj
 #4   0x004090f0 in
_ZN11nsXPConnect10WrapNativeEP9JSContextP8JSObjectP11nsISupportsRK4nsIDPP26nsIXPConnectJSObjectHolder
 #5   0x000964e8 in
_ZN24nsHTMLPluginObjElementSH17GetPluginJSObjectEP9JSContextP8JSObjectP17nsIPluginInstancePS3_S6_
 #6   0x00095ed0 in
_ZN19nsHTMLExternalObjSH10PostCreateEP25nsIXPConnectWrappedNativeP9JSContextP8JSObject
 #7   0x0066f604 in
_ZN16XPCWrappedNative12GetNewOrUsedER14XPCCallContextP11nsISupportsP21XPCWrappedNativeScopeP18XPCNativeInterfacePPS_
 #8   0x00669e40 in
_ZN10XPCConvert24NativeInterface2JSObjectER14XPCCallContextPP26nsIXPConnectJSObjectHolderP11nsISupportsPK4nsIDP8JSObjectPj
 #9   0x0066922c in
_ZN10XPCConvert13NativeData2JSER14XPCCallContextPlPKvRK9nsXPTTypePK4nsIDP8JSObjectPj
 #10  0x00672380 in _ZN16XPCWrappedNative10CallMethodER14XPCCallContextNS_8CallModeE
 #11  0x006682c4 in _Z19XPC_WN_GetterSetterP9JSContextP8JSObjectjPlS3_
 #12  0x040279c8 in js_Invoke
 #13  0x04027c14 in js_InternalInvoke
 #14  0x0403a1f4 in js_GetProperty
 #15  0x0402de08 in js_Interpret
 #16  0x04027a08 in js_Invoke
 #17  0x0071cc68 in
_ZN19nsXPCWrappedJSClass10CallMethodEP14nsXPCWrappedJStPK15nsXPTMethodInfoP17nsXPTCMiniVariant
 #18  0x050688ec in PrepareAndDispatch
 #19  0x05069290 in SharedStub
 #20  0x00261404 in
_ZN22nsEventListenerManager18HandleEventSubTypeEP16nsListenerStructP11nsIDOMEventP17nsIDOMEventTargetjj
 #21  0x00261b24 in
_ZN22nsEventListenerManager11HandleEventEP14nsIPresContextP7nsEventPP11nsIDOMEventP17nsIDOMEventTargetjP13nsEventStatus
 #22  0x00297938 in
_ZN16nsGenericElement14HandleDOMEventEP14nsIPresContextP7nsEventPP11nsIDOMEventjP13nsEventStatus
 #23  0x00297a9c in
_ZN16nsGenericElement14HandleDOMEventEP14nsIPresContextP7nsEventPP11nsIDOMEventjP13nsEventStatus
 #24  0x004d6ac8 in
_ZN17nsHTMLFormElement14HandleDOMEventEP14nsIPresContextP7nsEventPP11nsIDOMEventjP13nsEventStatus
 #25  0x00297a9c in
_ZN16nsGenericElement14HandleDOMEventEP14nsIPresContextP7nsEventPP11nsIDOMEventjP13nsEventStatus
 #26  0x00297a9c in
_ZN16nsGenericElement14HandleDOMEventEP14nsIPresContextP7nsEventPP11nsIDOMEventjP13nsEventStatus
 #27  0x00297a9c in
_ZN16nsGenericElement14HandleDOMEventEP14nsIPresContextP7nsEventPP11nsIDOMEventjP13nsEventStatus
 #28  0x00297a9c in
_ZN16nsGenericElement14HandleDOMEventEP14nsIPresContextP7nsEventPP11nsIDOMEventjP13nsEventStatus
 #29  0x00297a9c in
_ZN16nsGenericElement14HandleDOMEventEP14nsIPresContextP7nsEventPP11nsIDOMEventjP13nsEventStatus
 #30  0x00220654 in
_ZN18nsHTMLImageElement14HandleDOMEventEP14nsIPresContextP7nsEventPP11nsIDOMEventjP13nsEventStatus
 #31  0x00234d74 in
_ZN19nsEventStateManager22GenerateMouseEnterExitEP14nsIPresContextP10nsGUIEvent
 #32  0x002307e4 in
_ZN19nsEventStateManager14PreHandleEventEP14nsIPresContextP7nsEventP8nsIFrameP13nsEventStatusP7nsIView
 #33  0x002e85ac in
_ZN9PresShell19HandleEventInternalEP7nsEventP7nsIViewjP13nsEventStatus
 #34  0x002e8474 in
_ZN9PresShell11HandleEventEP7nsIViewP10nsGUIEventP13nsEventStatusiRi
 #35  0x003aab64 in _ZN13nsViewManager11HandleEventEP6nsViewP10nsGUIEventi
 #36  0x003aa070 in _ZN13nsViewManager13DispatchEventEP10nsGUIEventP13nsEventStatus
 #37  0x003b3e30 in _Z11HandleEventP10nsGUIEvent
 #38  0x003baf74 in _ZN11nsChildView13DispatchEventEP10nsGUIEventR13nsEventStatus
 #39  0x003bb000 in _ZN11nsChildView19DispatchWindowEventER10nsGUIEvent
 #40  0x003bb0ac in _ZN11nsChildView18DispatchMouseEventER12nsMouseEvent
 #41  0x003bc1e8 in -[ChildView mouseMoved:]
 #42  0x003bc124 in -[ChildView mouseMoved:]
 #43  0x9336e63c in -[NSWindow sendEvent:]
 #44  0x000323e0 in -[BrowserWindow sendEvent:]
 #45  0x930ce328 in -[NSApplication sendEvent:]
 #46  0x930ca524 in -[NSApplication run]
 #47  0x930d2598 in NSApplicationMain
 #48  0x0000478c in _start (crt.c:267)
 #49  0x0000460c in start

Thread 1:
 #0   0x90074328 in mach_msg_trap
 #1   0x90006670 in mach_msg
 #2   0xc00076cc in __ape_internal
 #3   0xc0000dd0 in __ape_agent
 #4   0x90021428 in _pthread_body

Thread 2:
 #0   0x90025e8c in select
 #1   0x0101c67c in poll
 #2   0x01018e50 in _pr_poll_with_poll
 #3   0x001731ac in _ZN24nsSocketTransportService3RunEv
 #4   0x05052a34 in _ZN8nsThread4MainEPv
 #5   0x0101a2bc in _pt_root
 #6   0x90021428 in _pthread_body

Thread 3:
 #0   0x9003f188 in semaphore_wait_signal_trap
 #1   0x9003efa4 in _pthread_cond_wait
 #2   0x010154f8 in PR_WaitCondVar
 #3   0x001421a4 in _ZN12nsDNSService15DequeuePendingQEv
 #4   0x00141bd0 in _ZN12nsDNSService3RunEv
 #5   0x05052a34 in _ZN8nsThread4MainEPv
 #6   0x0101a2bc in _pt_root
 #7   0x90021428 in _pthread_body

Thread 4:
 #0   0x90042d68 in semaphore_timedwait_signal_trap
 #1   0x9003ef94 in _pthread_cond_wait
 #2   0x010152bc in pt_TimedWait
 #3   0x0101550c in PR_WaitCondVar
 #4   0x05056348 in _ZN11TimerThread3RunEv
 #5   0x05052a34 in _ZN8nsThread4MainEPv
 #6   0x0101a2bc in _pt_root
 #7   0x90021428 in _pthread_body

Thread 5:
 #0   0x9003f188 in semaphore_wait_signal_trap
 #1   0x9003efa4 in _pthread_cond_wait
 #2   0x010154f8 in PR_WaitCondVar
 #3   0x05053b20 in _ZN12nsThreadPool10GetRequestEP9nsIThread
 #4   0x0505440c in _ZN20nsThreadPoolRunnable3RunEv
 #5   0x05052a34 in _ZN8nsThread4MainEPv
 #6   0x0101a2bc in _pt_root
 #7   0x90021428 in _pthread_body

Thread 6:
 #0   0x9003f188 in semaphore_wait_signal_trap
 #1   0x9003efa4 in _pthread_cond_wait
 #2   0x90824180 in -[NSConditionLock lockWhenCondition:]
 #3   0x933515f4 in -[NSUIHeartBeat _heartBeatThread:]
 #4   0x9081cd38 in forkThreadForFunction
 #5   0x90021428 in _pthread_body

Thread 7:
 #0   0x90074328 in mach_msg_trap
 #1   0x90006670 in mach_msg
 #2   0x901490a8 in __CFRunLoopRun
 #3   0x9018157c in CFRunLoopRunSpecific
 #4   0x905e2d90 in _ZN21XIOAudioDeviceManager18NotificationThreadEPS_
 #5   0x905e2cac in _ZN9CAPThread5EntryEPS_
 #6   0x90021428 in _pthread_body

Thread 8:
 #0   0x9003f188 in semaphore_wait_signal_trap
 #1   0x9003efa4 in _pthread_cond_wait
 #2   0x90233454 in TSWaitOnSemaphoreCommon
 #3   0x9023c298 in TimerThread
 #4   0x90021428 in _pthread_body

Thread 9:
 #0   0x9003f188 in semaphore_wait_signal_trap
 #1   0x9003efa4 in _pthread_cond_wait
 #2   0x90233454 in TSWaitOnSemaphoreCommon
 #3   0x90233d94 in DeferredTaskThread
 #4   0x90021428 in _pthread_body

PPC Thread State:
  srr0: 0x01f49354 srr1: 0x0208f030                vrsave: 0x00000000
   xer: 0x00000000   lr: 0x050830ec  ctr: 0x01f49354   mq: 0x00000000
    r0: 0x050831f4   r1: 0xbfffc070   r2: 0x44048282   r3: 0x02f21ff0
    r4: 0x0089bdb8   r5: 0xbfffc100   r6: 0x02bb62a0   r7: 0xbfffc2c0
    r8: 0x74481fcc   r9: 0x01f4935c  r10: 0x00000002  r11: 0x050b3058
   r12: 0x01f49354  r13: 0x02546058  r14: 0x00000000  r15: 0xbfffcaa8
   r16: 0x019312e0  r17: 0xbfffc690  r18: 0xbfffc5d4  r19: 0xbfffc5d0
   r20: 0xbfffc2c0  r21: 0x01aa0630  r22: 0xbfffc160  r23: 0x02bb62a0
   r24: 0xbfffc440  r25: 0x01aa2e70  r26: 0xbfffc350  r27: 0x01aa2e70
   r28: 0x02f21ff0  r29: 0xbfffc2b0  r30: 0xbfffc170  r31: 0x00000000



Reproducible: Always

Steps to Reproduce:
1.Load .Mac Homepage using my account
2.Edit the main menu which shows all web page entry points
3.Wait a few seconds, then it crashes

Actual Results:  
Navigator shuts down unexpectedly.

Comment 1

15 years ago
Reporter, for future reference, crash reports should be attached to your bugs as
a text file, and not quoted in a bug comment.

*** This bug has been marked as a duplicate of 167178 ***
Severity: normal → critical
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Keywords: crash
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.