a profile created with -CreateProfile will cause a slew of assertions because <profile>/bookmarks.html does not exist.

VERIFIED FIXED in M14

Status

Core Graveyard
Profile: BackEnd
P3
normal
VERIFIED FIXED
19 years ago
2 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: racham)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

linux and windows (probably mac too.)

create a profile with -CreateProfile.

on launch, you get a bunch of assertions:

Start reading in bookmarks.html
Opening file bookmarks.html failed
Error: "unable to open file" at file nsBookmarksService.cpp, line 3191
Break: at file nsBookmarksService.cpp, line 3191
Warning: "unable to load datasource 'rdf:bookmarks'" at file
nsXULContentSink.cpp, line 1725
Start reading in bookmarks.html
Opening file bookmarks.html failed
Error: "unable to open file" at file nsBookmarksService.cpp, line 3191
Break: at file nsBookmarksService.cpp, line 3191
Warning: "unable to load datasource 'rdf:bookmarks'" at file
nsXULContentSink.cpp, line 1725
Start reading in bookmarks.html
Opening file bookmarks.html failed
Error: "unable to open file" at file nsBookmarksService.cpp, line 3191
Break: at file nsBookmarksService.cpp, line 3191
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M11
(Assignee)

Comment 1

19 years ago
Accepting the bug.

Updated

19 years ago
Target Milestone: M11 → M12

Comment 2

19 years ago
Need to merge this code in with the new profile case.
(Assignee)

Updated

18 years ago
Target Milestone: M12 → M13
(Assignee)

Comment 3

18 years ago
I have a fix coming in with the new changes.
Marking TFV to M13.
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

18 years ago
-CreateProfile is fixed.

now....

case 1 : mozilla -CreateProfile foo - a profile named foo is created in the
         default profiles dir and browser is launched with that profile.

case 2 : mozilla -CreateProfile "foo c:\bar" - a profile named foo is created in
         the chosen path (c:\bar) and browser is launched with that profile.

note : quotes are mandatory to pass arguments in case 2.

true for all platforms.
Marking fixed.

Updated

18 years ago
Status: RESOLVED → REOPENED

Updated

18 years ago
Resolution: FIXED → ---

Comment 5

18 years ago
the last comments are true, using -CreateProfile with a profile name or with
profile name and user supplied directory (all in quotes) does as it says BUT
these profiles do not display in Profile Manager in subsequent launches.  They
do get created with the commands as verified by viewing on explorer.  They do
launch and you can set bookmarks, prefs etc but you cannot use that profile
again except with mozilla -P foo or mozilla -P "testing d:\bar".
Using the -installer, -SelectProfile, -ProfileManager arguments bring up the
Profile Manager without the newly created profiles, foo and testing
build 1999121008
(Assignee)

Comment 6

18 years ago
Grace,
I just tested this on my windows box with today's build.
Had no problems. I see the profile getting added to the list
and displayed when ran with -ProfileManager option. Will
update the report with Linux and Mac behavior soon. If there are
specific steps to reproduce this problem...please udpate the
bug.
(Assignee)

Comment 7

18 years ago
Linux is OK too....waiting for Mac to unstuff the sit file.
(Assignee)

Updated

18 years ago
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 8

18 years ago
Haven't seen this in recent builds.  If you see it again, please reopen the bug.

Updated

18 years ago
Status: RESOLVED → REOPENED

Updated

18 years ago
Resolution: WORKSFORME → ---

Comment 9

18 years ago
testing with 1999121608 builds
WinNT   -CreateProfile cases 1 and 2 work
subsequent launches with -ProfileManager, -SelectProfile DO NOT DISPLAY the
profiles created above

Win95 works as noted in this bug report

Linux -CreateProfile foo brings up the CreateProfileWizard -bad
      -CreateProfile "foobar $HOME/foobar does create profile in directory and
launches, subsequent launches display the profiles

Mac - these cases not available as written, can use ProfileWizard and select
folder to accomplish the same thing however
(Assignee)

Updated

18 years ago
Target Milestone: M13 → M14
(Assignee)

Comment 10

18 years ago
This looks like an registry update problem.
Let me look into this in detail and see what's
different on different platforms.
I just fixed #23744, which was caused because when you used -CreateProfile, we
never created prefs.js

this should help fix other CreateProfile issues.

Updated

18 years ago
Component: Profile Manager → Profile Manager BackEnd

Comment 12

18 years ago
Moving all Profile Manager bugs to new Profile Manager Backend component.
Profile Manager component to be deleted.

Comment 13

18 years ago
Bhuvan,
Using builds 20000120 for both Linux and Windows (95 and NT) - I am seeing the
same behavior I have reported above.  New profiles get created but are not seen
using mozilla -SelectProfile/-ProfileManager etc. They do get created and can be
viewed  BUT I used the BiggerRegToy tool and cannot see them in mozregistry.dat
which would explain why they do not show up.  They do seem to appear in registry
on Linux.
(Assignee)

Comment 14

18 years ago
Registry update request has been made after this command line option. Should 
make all problems go away. Marking fixed.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 15

18 years ago
build  2000-01-28-12-M14/
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.