Closed Bug 1753638 Opened 2 years ago Closed 8 months ago

[CA][amazon.ca] The Country and Province dropdowns are not previewed nor autofilled

Categories

(Toolkit :: Form Autofill, defect, P3)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
Tracking Status
firefox96 --- affected
firefox97 --- affected
firefox98 --- affected

People

(Reporter: sbadau, Unassigned)

References

(Blocks 3 open bugs)

Details

(Whiteboard: [fxcm-addr-compatibility])

Attachments

(3 files)

Affected Versions:

Nightly 98.a1, Beta 97 and Release 96

Tested on:

MacOS 11.6
Windows 10

Preconditions:

browser.search.region US,CA
extensions.formautofill.addresses.enabled true
extensions.formautofill.supportedCountries US,CA
download latest Firefox Nightly with region locale
have a complete address already saved in about:preferences#privacy

Steps to reproduce:

  1. Reach the address form on amazon.ca
  2. Using the autofill feature, hover over any saved address entry to check the autofill preview - observe the Country and Province dropdowns
  3. Using the autofill feature, select any saved address entry.

Expected Results:

  1. The preview should be shown also on the Country and Province dropdowns.
  2. The Country and Province dropdowns should be auto-filled.

Actual Results:

  1. The preview is not done on the Country and Province dropdowns.
  2. The Country and Province dropdowns are not auto-filled.

Notes:

Severity: S3 severity.
Reproducible on Chrome: No.

Summary: [CA][amazon.ca] The Country and Province dropdowns are not previewed, autofilled nor highlighted → [CA][amazon.ca] The Country and Province dropdowns are not previewed nor autofilled
Severity: S4 → S3

These two select elements have an explicit autocomplete="off", which we respect with address autofill but Chrome ignores. We also ignore autocomplete="off" for credit cards, so maybe this is yet another reason to align address autofill to credit card autofill.

See Also: → 1753630, 1751159
Priority: -- → P3
Depends on: 1754879

The issue is still reproducible and beside that "Postal code" field isn't autofilled.
Tested on Windows 10 x64, macOS 11.6 using the latest Nightly 104.0a1, Beta 103.0b2 and Firefox 102.0.

Whiteboard: [fxcm-addr-compatibility]
Blocks: 1831127
Attached file amazon.ca.html

The issue is still reproducible on Firefox Nightly 115.0a1 (2023-05-25).
"Province" and "Postal code" fields aren't autofilled and autofill can't be triggered via "Postal code" field.

Blocks: 1835644
Attached video 2023-06-19_15h03_18.mp4

The Province/Territory is still not previewed, but it is autofilled correctly now. Also, the same behavior is present for the Country/Region field. As you can see in the screen recording, the Country is changed accordingly and the form fields are updated, but the autofill is not working on the first try. The same behavior when autofill with a different Country/Region again. Nightly 116.0a1 (2023-06-19).

Province/Territory is not previewed because the field is not implemented with <select>, it is implemented with <span>. The same behavior happens in Chrome as well. We don't have a plan to support showing preview for this case.

I'll close this bug because we can now autofill Country and Province field

Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.