Closed Bug 1753656 Opened 2 years ago Closed 10 months ago

[CA][thebay.com] The autofill dropdown is not triggered and the autofill functionality is not working for Address 1 and Email fields

Categories

(Toolkit :: Form Autofill, defect, P3)

Desktop
All
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox96 --- affected
firefox97 --- affected
firefox98 --- affected

People

(Reporter: ailea, Unassigned)

References

(Blocks 2 open bugs, )

Details

(Whiteboard: [fxcm-addr-compatibility])

Attachments

(3 files)

Attached video 2022-02-03_15h14_51.mp4

Affected Versions:

Nightly 98.a1, Beta 97 and Release 96

Tested on:

MacOS 11
Windows 10

Preconditions:

browser.search.region CA
extensions.formautofill.addresses.enabled - true
extensions.formautofill.supportedCountries US,CA
download latest Firefox Nightly with region locale
have a complete address already saved in about:preferences#privacy

Steps to reproduce:

  1. Reach the address form on thebay.com
  2. Using the autofill feature, select any saved address entry.
  3. Click in the Address 1/Email fields.

Expected Results:

  1. All the fields should be successfully autofilled.
  2. The address autofill dropdown should be displayed for all fields.

Actual Results:

  1. The Address 1/Email fields are not autofilled. Note that there is an address 2 (optional) field that works correctly and it displays the second and third line from the street address in about:preferences. The main street is not displayed as expected in Address 1 field.
  2. The address autofill dropdown is not displayed for Address 1/ Email fields.

Notes:

Reproducible on Chrome: Partially. In Chrome the Address 1 and Email fields are also not autofilled, but both fields (Address 1 and Email) successfully trigger the autofill dropdown and can be autofilled by selecting a value from their dropdown.
For the Clear Form option that is not displayed in the autofill dropdown see bug 1753710.

Attached video 2022-02-03_15h22_50.mp4

Address 1/Email fields Fx vs Chrome behavior.

Summary: [CA][newegg.ca] The autofill dropdown is not triggered and the autofill functionality is not working for Address 1 and Email fields → [CA][thebay.com] The autofill dropdown is not triggered and the autofill functionality is not working for Address 1 and Email fields
Priority: -- → P3

One issue is that the address 1 field has an autocomplete = "off". The other issue is that when we call getInfo with the email field, we aren't getting an address type associated with this email. All the other fields (that work) have addressType: "shipping" so they all get consolidated into the same section while email falls out. I guess we either have to update our matching in the getInfo function or update the low level getAutocompleteInfo function so that it can make that determination. Most likely it's something we're going to have to do in getInfo and not getAutocompleteInfo because there's no autocomplete attribute associated with this email field.

Depends on: 1754879
Attached video 2022-06-29_14h54_17.mp4

Tested again in Beta 103.0b1 and the latest Nightly 104.0a1 and the following behavior is present now: Address 1 and Email Address fields are still not autofiled, but both fields (Address 1 and Email) successfully trigger the autofill dropdown and can be autofilled by selecting a value from their dropdown (as in Chrome). Somehow those two fields seems to be separate from the others. If there is another root cause for this issue, just let me know and I'll log a new bug for it.

Whiteboard: [fxcm-addr-compatibility]

As mentioned by :tgiles in Comment 2, all fields other than address 1 and email have autocomplete=shipping, so they are all treated as in a different "shipping" section. When we autofill, we only autofill fields that are in the same section, this is the expected behavior.

I believe the clear form issue is fixed after landing Bug 1829670 so I'm going to close this bug as WONT FIX.
Hi Alin, could you help verify this issue? thanks!

Status: NEW → RESOLVED
Closed: 10 months ago
Flags: needinfo?(ailea)
Resolution: --- → WONTFIX

Indeed, the clear form option is now displayed and it works properly in the latest Nightly build 114.0a1 (2023-04-26).

Flags: needinfo?(ailea)
You need to log in before you can comment on or make changes to this bug.