OBJECT element never render its contents

VERIFIED FIXED

Status

()

Core
Layout
P2
major
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: emk, Assigned: Nisheeth Ranjan)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DOGFOOD, URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Steps to reproduce:
1. Launch mozilla.
2. Go to the following testcase.

Actual result:
Gray placeholder box drawn, and never go away.
I'm using 1999102808 build mozilla.exe on WinNT4 (SP5).

Expected result:
Mozilla should render OBJECT's contents when it cannnot render
object itself.
See the HTML spec. 13.3.1. ( http://www.w3.org/TR/REC-
html40/struct/objects.html#h-13.3.1 )
See also Bug 1994.
Mozilla M10 build works as expected.
(Reporter)

Comment 1

18 years ago
Created attachment 2477 [details]
testcase
(Reporter)

Updated

18 years ago
(Reporter)

Comment 2

18 years ago
This bug prevents EMBED into OBJECT is rendered.
See the above URL.

Updated

18 years ago
Assignee: troy → dp
Severity: normal → major
Priority: P3 → P2
Whiteboard: DOGFOOD

Comment 3

18 years ago
dp and Pam, this is because the pres shell's CantRenderReplacedElement() code
was commented out by Nisheeth to work around the crash

Looking at the log for nsPresShell.cpp this still isn't enabled and it's causing
problems for OBJECT, EMBED, and IMG

Comment 4

18 years ago
Nisheeth:
Gagan checked in his change for the 'url redirect' fix yesterday.
This should mean you/we can test with the temporary
fix(CantRenderReplacedElement()) removed.
Let me know what's up and I can help test.

-pn
(Assignee)

Updated

18 years ago
Assignee: dp → nisheeth
(Assignee)

Comment 5

18 years ago
Re-assigning this bug to myself.  Putting gagan and dp on the cc list.
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

18 years ago
I removed my hack and tested this test case as well as the home.netscape.com,
mozilla.org, excite, and yahoo.  Everything looks good.  So it looks like the
earlier hack is no longer needed.  I've backed it out.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 7

18 years ago
Fixed in the Nov 16th (1999111608) build.
You need to log in before you can comment on or make changes to this bug.