Closed Bug 1754395 Opened 8 months ago Closed 3 months ago

Unable to choose "Time slot" on boots.com with ETP - Strict enabled

Categories

(Core :: Privacy: Anti-Tracking, defect, P3)

Firefox 98
ARM
Android
defect

Tracking

()

VERIFIED FIXED
103 Branch
Tracking Status
firefox103 --- fixed

People

(Reporter: oanaarbuzov, Assigned: twisniewski)

References

(Blocks 1 open bug, )

Details

Attachments

(2 files)

Attached image StrictVsStandard.png

Environment:
Browser / Version: Firefox Nightly 98.0a1 (🦎 98.0a1-20220207065816), Firefox Release 96.3.1 (🦎 96.0.3-20220126154723)
Operating System: Google Pixel 5 (Android 12) - 1080 x 2340 pixels, 19.5:9 ratio (~432 ppi density), Samsung Galaxy S8 (Android 9) - 1440 x 2960 pixels, 18.5:9 ratio (~570 ppi density)

Prerequisites:
ETP - Strict enabled.

Steps to reproduce:

  1. Navigate to https://www.boots.com/health-pharmacy-advice/vaccinations/chickenpox-vaccination-service
  2. Scroll down the page and tap "Book now" button.
  3. On "Appointment" page, select the desired options (e.g 1 member, appointment for myself - Yes, mark the check-box) and tap "Continue" button.
  4. Fill in the town/postcode (e.g 10001) and tap "Find store" button.
  5. Tap "Choose time slot" button and observe behavior.

Expected Behavior:
"Time slots" popup is not triggered, allowing the selection of date and time.

Actual Behavior:
Nothing happens, "Time slots" popup is not triggered.

Notes:

  1. Screenshot attached.
  2. The issue is not reproducible with ETP - Standard.
  3. On Android 12 device, on Firefox Nightly with ETP - Strict enabled, the "Location" search remains in loading state.
    https://prnt.sc/26ry0q3
Severity: -- → S3

I see this in the console when I click the "choose time slot" button:

Uncaught ReferenceError: cmCreateElementTag is not defined

This is Eluminate. Our shim doesn't stub out this (and many other) functions in Eluminate, but making it a no-op seems to suffice for this site, so it seems like a simple fix.

Blocks: 1773100
Assignee: nobody → twisniewski
Status: NEW → ASSIGNED
Pushed by twisniewski@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/13d34fd1e880
add more methods and properties which some sites expect to SmartBlock's Eluminate shim; r=ksenia,webcompat-reviewers
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 103 Branch

The URL was no longer valid, but I found a different on: URL: https://www.boots.com/health-pharmacy-advice/vaccinations/meningitis-b
The issue is fixed, "Time slots" popup is triggered now.
https://prnt.sc/fe92Cy6CH1Yo

Tested with:
Browser / Version: Firefox Nightly 105.0a1 (🦎 105.0a1-20220816095503)
Operating System: Google Pixel 5 (Android 12) - 1080 x 2340 pixels, 19.5:9 ratio (~432 ppi density), Samsung Galaxy S8 (Android 9) - 1440 x 2960 pixels, 18.5:9 ratio (~570 ppi density)

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.